Pymakr cannot connect after firmware upgrades



  • Yesterday I started playing with my newly arrived WiPy 2.0. As said on the box, I went to https://www.pycom.io/gettingstarted

    There were some glitches:

    • The instructions say that that the IDE Pymakr "will detect that your WiPy firmware must be updated and will prompt you to do so. Press continue to deploy the latest firmware on the board. It’s important that you do this first before trying any WiFi or Bluetooth scripts on the board.". This did not happen.

    • At this moment I was able to connect to my WiPy using a USB serial connection, from Pymakr.

    • Because I thought that I needed to upgrade the firmware, I went and used the The WiPy 2.0 stand-alone updater tool. This upgrade was succesful.

    But, now, I am not able to connect to my WiPy 2.0 anymore using USBSerial ("Connecting to a Pycom device... Error while communicating with the Pycom device! (click to attempt to reconnect)"). I tried multiple computers, safeboot, the works. No succes whatsoever.

    My WiPy is version 0.9.1.b1. I can FTP and Telnet to it, but Pymakr (1.0.0.b5) won't connect (over either Wifi or Serial). I want the serial connection from Pymakr to work.

    Does anybody have any clue?



  • Good to hear @livius and @rogierb!

    Sounds like we can close this topic now. If anyone still has similar issues, please create a new topic.



  • with pymakr b7 and todays firmware 9.7
    i can connect to my WiPy without any problems by COM :)



  • @Ralph Just upgraded to release '0.9.6.b1' and pymakr 1.0.0.b7. Everything works awesome :) Thank you! Now, let's start playing!! :D



  • @Ralph
    No, i am talking only about connect by serial (COM) in Pymakr.
    I can connect to my WiPy2 by telnet or ftp in all firmware versions.
    I can connect by serial throught any aplication like COM port monitor or putty
    but i am not able to connect by Pymakr.

    A screenshot of the pycom console for example
    i am not currently by my WiPy but this is "standard" info something like
    connection fialed click once again to reconect
    and clicking once again does produce same lines and prompt to click once again...



  • hi @livius, thanks for the review. I tested both 9.5 and 9.6 firmware vesions and I'm able to connect using serial and telnet.

    Did you try both serial and telnet, or only one of them? There is an issue in the situation where your wipy is connected through your home router and you're connecting to it's IP address over telnet. In this case it takes about 30 seconds (or 3 pymakr connection tries) before telnet is available after a device reboot. That could be mistaken for not being able to connect at all.

    Could this be your problem? If not, could you provide more info on what happens when trying to connect to the latest firmware? A screenshot of the pycom console for example. Thanks in advance!



  • this is my review of my WiPy2.0

    can connect:

    pymakr b7
    firmware 9.5!
    

    can't connect:

    pymakr b7
    firmware 9.6 (newest)
    ---
    pymakr b6
    firmware 9.5
    

    any previous firmware execpt very early from 2 months ago and from the same time pymakr
    is unable to connect by serial port



  • @jonirons @rogierb @livius @stevePy Last friday, pymakr 1.0.0.b7 was released. It has a lot of bugfixes that relate to the issues all of you posted in this topic. Please try this version (together with the latest firmware) and let me know if this helps with your issues. I'd love to hear your feedback, so I can get an idea of any remaining issues.



  • @Ralph some progress - the new firmware seems to be stabler under wifi, but not usb.

    USB still throws a stack widget error, but wifi seems to be moderately stable - had it fail once when I disconnected screen.

    Until the basics like realtime clock are there, I need to use other platforms so I'll come back in a while and see if the platform has matured. Until then I'm using the WiPy under ESP32 IDT.



  • @richardkt Next week we'll release a new version of Pymakr, as well as a firmware update.



  • @Ralph Hi, any idea on when the fixes will be released?



  • Hi @rogierb, There are two bugs responsible for this behaviour, with the versions you are using. One in the firmware that causes the USB Serial not to function and one in Pymakr that causes the QStackedWidget error. Both bugs have now been fixed and will be released soon.



  • @Ralph Hi Ralph, I just upgraded to Pymakr 1.0.0.b6 and Wipy to (sysname='WiPy', nodename='WiPy', release='0.9.4.b1', version='bc42ea7 on 2016-11-14', machine='WiPy with ESP32')

    Still these issues:

    • Connecting over USBSerial doesn't work (Yes, I have the correct REPL code on boot.py)
    • Connecting over Wifi does work, but Pymakr crashes with "QStackedWidget::setCurrentWidget: widget 0x7fb7b85bdf70 not contained in stack"-error

    Connecting over wifi through telnet and doing some stuff on the command line works fine.

    (edit: after displaying the "setCurrentWidget"-error, my telnet is dead, I need to reboot the device)


  • Pybytes Beta

    @Ralph thx for the answer. I will give it a try tomorrow.



  • @PatSenn
    You can indeed find the boot.py and main.py files in the /flash folder. Use FTP to download them to a folder on your pc. After this, you can go to Pymakr, create a new project for this folder and start coding and syncing code to the device from there. You can also skip the FTP download part and create new boot and main files from Pymakr.
    Let me know if this helps you to get started.



  • @jonirons said in Pymakr cannot connect after firmware upgrades:

    We really do need to know what is working, what isn't, and when it might be fixed.

    I completely agree with you and we are working on improving this. Step one is making more use of the new repo's on github for tracking issues.

    My colleagues will take care of your watchdog questions in those topics, since that's not my field of expertise.



  • @livius thanks for notifying this, l'll check if our update system is causing this version information error.

    I'm also still unable to connect Pymakr with the latest firmware version. This issue is probably the cause of this, perhaps somehow also involved in preventing connection over serial. We'll be working on a fix for this very soon.



  • @jonirons @Ralph
    Maybe I am just to new to this system, but I am having problems locating boot.py. I searched the folders that I could and found nothing. How do I view the '/flash' folder?



  • @Ralph Yes - I tried that.
    The loop waiting for "not wlan.isconnected() caused a watchdog timeout (took 8 seconds to finish) and watchdog timer HALTED the machine (I've posted this issue on this forum). The only way out was to wipe the flash. I then removed that code from boot.py, and put it in a sample.py file, and discovered that watchdog feeding is not available (also posted somewhere on the forum).

    The difference between my code and the example is the use of 'dhcp'. I've also posted somewhere or other that dhcp on WiPy2 takes 10 seconds, whereas on WiPy 1 it takes a bit under 2 seconds.

    If 'dhcp' is not yet properly supported this would be useful to know, as would watchdog feeding, no support for RTC etc.

    We really do need to know what is working, what isn't, and when it might be fixed.

    More particularly those who haven't bought a device yet need to be advised that the software doesn't yet support all features.

    if machine.reset_cause() != machine.SOFT_RESET:
    wlan.init(WLAN.STA)
    # configuration below MUST match your home router settings!!
    wlan.ifconfig(config=('192.168.178.107', '255.255.255.0', '192.168.178.1', '8.8.8.8'))

    if not wlan.isconnected():
    # change the line below to match your network ssid, security and password
    wlan.connect('mywifi', auth=(WLAN.WPA2, 'mywifikey'), timeout=5000)
    while not wlan.isconnected():
    machine.idle() # save power while waiting



  • Pymakr can not connect to WiPy2 with newest firmware also.

    i got message

    pymakr - Error getting versions information
    ---------------------------
    The versions information could not be downloaded for the last 7 days. Please go online and try again.
    ---------------------------
    OK   
    ---------------------------
    

    and trying to connect by pymakr

    Error while communicating with the Pycom device! (click to attempt to reconnect)
    Connecting to a Pycom device...
    

    and strange it now restart my device
    tested on Windows 10


Log in to reply
 

Looks like your connection to Pycom Forum was lost, please wait while we try to reconnect.