Cannot connect LoPy via WIFI after firmware update



  • Hi,

    I have just updated my LoPy firmware to version 1.7.9.b3.

    Since the update, I can not reconnect anymore to the board via wifi.

    My computer does not find anymore the wifi AP ssid.
    Trying to force to connect to LoPy-wlan-xxxx but it does not work

    Briefly put when connected via Serial mode, the board returns me the wifi AP SSID but this address is no more reachable from my computer since the LoPy firmware update.

    This prevents me to upload my .py files to LoPy through FTP.

    Everything else seems to work (device led flashing, connecting via Serial, ...)
    Reseting the device didn't help

    Any Idea ?

    Thanks a lot for your help.

    Nicolas



  • Hi , @bmarkus @livius

    Following the advice of livius, I issued the following code in the terminal (connected via serial)

    from network import WLAN
    wlan = WLAN(mode=WLAN.AP, ssid='LoPy-wlan-xxxx')

    and this worked! The LoPy wifi AP was directly discoverable from my computer.

    This is not regular but it works. There is probably an error in boot/init file coming with the firmware ...

    Ncolas



  • Hi @bmarkus,

    I confirm mine does not work anymore since WIFI is no more available.

    I updated with the Mac OS x update utility tool.

    In the meantime and since I bought 2 LoPy, I tried to connect my second one (with the shipped firmware). With this one, the wifi AP showed directly.
    I connected the second LoPy to the same board (just to change one thing at a time).

    I tried to update once again my first LoPy but same result.

    Of course, I highly hesitate to update my second one. Unfortunately I have to update because there is a bug in the shipped firmware version that prevents me from connecting to TTN network (which is btw the reason why I bought such a device).

    Don't know what to to since I'm a newbie with PyCom devices ...

    Regards,

    Nicolas



  • Just updated LoPy to 1.7.9.b3 Both connection from ATOM and FTP with Filezilla via WiFi works fine to the default 192.168.4.1 AP.



  • Hi @livius

    Thank you for your reply.

    To be honest with you, I don't know exactly from which firmware I come from. I received my LoPy yesterday and this is my first firmware update. I think the initial firmware was 0.9.x.bx.

    All I know is that I could connect via wifi before updating the firmware.

    Here is what I received from pymakr when connecting via Serial-USB and after the firmware update:

    Wifi connected!
    Traceback (most recent call last):
    file "main.py", line 12, in <module>
    file "/flash/lib/nanogateway.py", line 95, in start
    file "/flash/lib/nanogateway.py", line 157, in _push_data
    ValueError: non hex-digit found

    Mycropython 1.8.6-747 ...

    Nicolas



  • @nicolas
    Will be good to know from which version you upgrade device and what you got on uart repl.
    Did you got some error there like "ssid not given"?

    Without this i can only assume that you are affected by this change
    https://forum.pycom.io/post/8950

    your code must init wifi with ssid like below

    wlan = WLAN(mode=WLAN.STA_AP, ssid='LoPy-wlan-xxxx')
    

Log in to reply
 

Looks like your connection to Pycom Forum was lost, please wait while we try to reconnect.