New firmware release 0.9.3.b2


  • administrators

    Hello,

    We are pleased to announce that firmware version 0.9.3.b2 has been released today. We have fixed the broken FTP server issue from the previous version.

    These are the changes:

    Increase LWIP max number of sockets from 4 to 6.
    Add the PWM class to the machine module.
    Add the ADC class in the machine module.
    Correct UART interrupt enabling to pass the uart id.
    Fix bug when using node addresses >= 0x80000000 for LoRaWAN ABP join.
    Add API to add and remove LoRa channels.
    New LoRaWAN join API. Implement DR socket option.
    Add _thread module.

    We've also improved the updater tool in order to show a verbose output in case of a failure during the update. As usual, you can download the new firmware from:

    https://www.pycom.io/support/supportdownloads/
    (Under the Firmware Updates section)

    Please check the quick reference to see examples of using the ADC class, the PWM class and the _thread module while we update the docs with the full reference.

    https://docs.pycom.io/lopy/lopy/quickref.html

    I also want to mention that we published our iOS mobile App Pymate in the Apple App store. Go ahead and try it now!

    Cheers,
    Daniel



  • @liviusm, thanks for the pinned observation :)



  • This topic is "pinned" and is as a first on the list - but newer firmware topic exists



  • I do not have mac but did you checked real version it it was upgraded?

    import os
    os.uname()
    


  • FTP still not working for me after upgrading to pycom_update_0.9.3.b2.dmg



  • @matamune, thanks for your observation. There is a new version of the script that takes into account your findings. It should start now :) It's available in the usual place, and the file is named pycom_update_0.9.3.b2a.dmg



  • @Xykon I think I will put PyMakr to the side for a while, between FileZilla and putty I can do whatever I need. Your input has helped me get up to speed quickly. Thanks



  • Thanks guys that worked.

    Dale.



  • @matamune said in New firmware release 0.9.3.b2:

    bins = os.listdir(HERE_PATH+'/firmware')

    Yes! This makes the firmware updater working on the MacOs. I'm on El Capitain.

    To be a bit more specific, one need to apply the fix in here:
    /Applications/Pycom Firmware Update.app/Contents/Resources/src/lopyupdate.py


  • Global Moderator

    @MainSheet I only used PyMakr very briefly (it keeps turning the awfully bright LED on and it's very annoying having to turn it off manually all the time) but it was working with the LoPy and the latest firmware.

    The only reasons I can think of why PyMakr can't connect to the serial port is that something else is blocking the COM port or there is something in your boot.py/main.py that's causing PyMakr to fail. You could try import os; import machine; os.mkfs('/flash'); machine.reset() to restore your flash memory to firmware defaults, it will re-create a boot.py with nothing but the code for serial REPL along with empty main.py and sys, cert, lib directories.

    As for not being able to connect via the network, did you try ping 192.168.0.118 from the command line? Did you try putty in telnet mode and FileZilla with correct settings?



  • Hi,
    I am on macOS Sierra and when I downloaded the newest version of the updater, I was not able to launch it.

    I debbuged it by launching it on the terminal and it says the file lopy.py did not find the folder 'firmware'.

    I took a look into the code and in the function __establishFirmwareVersion, line 426, I had to change bins = os.listdir('/firmware')by bins = os.listdir(HERE_PATH+'/firmware').
    Now it works correctly.



  • @Xykon , First, thanks for all your help, I have both units working now.
    Both units had zero byte files in the /flash folder. I believe this was a result of using the PyMakr sync project button, as that was the last tool I used to upload files.

    I still can not get the PyCom console in PyMAkr to load the REPL prompt. PyMakr is configured on COM4, the same port I used successfully for putty (serialmode).

    Connecting to a Pycom device...
    Error while communicating with the Pycom device! (click to attempt to reconnect)
    Connecting to a Pycom device...
    Error while communicating with the Pycom device! (click to attempt to reconnect)
    Connecting to a Pycom device...
    Error while communicating with the Pycom device! (click to attempt to reconnect)
    

    I also configured PyMakr for 192.168.0.118, still could not load the REPL prompt.

    S


  • Global Moderator

    @MainSheet For Unit1 it seems either your boot.py is missing the code for the serial REPL or it contains an error which prevents it from being executed. You should however be able to connect to it through Wifi and telnet / ftp to 192.168.4.1. You should check that your Wifi settings are correct when connecting to the module via Wifi. Can you try to ping 192.168.4.1 to check if your network connection to the module is working? You should at least be able to use putty in telnet mode to connect to 192.168.4.1. You can then run execfile('boot.py') to see if there are any errors in your boot.py.

    For Unit2 this seems to be able to connect to your Wifi AP. Check this one also with ping 192.168.0.118 to make sure it is reachable over the network. You should then be able to telnet & ftp to 192.168.0.118. Make sure that your Filezilla settings are correct as described here. In putty make sure you choose telnet protocol and not the default ssh.



  • @Xykon
    ok
    unit one does this

    ets Jun  8 2016 00:22:57
    
    rst:0x1 (POWERON_RESET),boot:0x13 (SPI_FAST_FLASH_BOOT)
    ets Jun  8 2016 00:22:57
    
    rst:0x10 (RTCWDT_RTC_RESET),boot:0x13 (SPI_FAST_FLASH_BOOT)
    configsip: 0, SPIWP:0x00
    clk_drv:0x00,q_drv:0x00,d_drv:0x00,cs0_drv:0x00,hd_drv:0x00,wp_drv:0x00
    mode:QIO, clock div:2
    load:0x3fff9010,len:8
    load:0x3fff9018,len:312
    load:0x40078000,len:2348
    ho 0 tail 12 room 4
    load:0x4009f000,len:1364
    entry 0x4009f2f8
    rtc v112 Sep 26 2016 22:32:10
    XTAL 40M
    frc2_timer_task_hdl:3ffda618, prio:22, stack:2048
    tcpip_task_hdlxxx : 3ffdede4, prio:18,stack:2048
    phy_version: 123, Sep 13 2016, 20:01:58, 0
    pp_task_hdl : 3ffea6b4, prio:23, stack:8192
    mode : softAP(24:0a:c4:00:bd:0f)
    dhcp server start:(ip: 192.168.4.1, mask: 255.255.255.0, gw: 192.168.4.1)
    dhcp server start:(ip: 192.168.4.1, mask: 255.255.255.0, gw: 192.168.4.1)
    

    (note: unit one never gets to a >>> prompt)

    Unit 2 gets

    ts Jun  8 2016 00:22:57
    
    rst:0x1 (POWERON_RESET),boot:0x13 (SPI_FAST_FLASH_BOOT)
    ets Jun  8 2016 00:22:57
    
    rst:0x10 (RTCWDT_RTC_RESET),boot:0x13 (SPI_FAST_FLASH_BOOT)
    configsip: 0, SPIWP:0x00
    clk_drv:0x00,q_drv:0x00,d_drv:0x00,cs0_drv:0x00,hd_drv:0x00,wp_drv:0x00
    mode:QIO, clock div:2
    load:0x3fff9010,len:8
    load:0x3fff9018,len:312
    load:0x40078000,len:2348
    ho 0 tail 12 room 4
    load:0x4009f000,len:1364
    entry 0x4009f2f8
    rtc v112 Sep 26 2016 22:32:10
    XTAL 40M
    frc2_timer_task_hdl:3ffda618, prio:22, stack:2048
    tcpip_task_hdlxxx : 3ffdede4, prio:18,stack:2048
    phy_version: 123, Sep 13 2016, 20:01:58, 0
    pp_task_hdl : 3ffea740, prio:23, stack:8192
    mode : softAP(24:0a:c4:00:12:c1)
    dhcp server start:(ip: 192.168.4.1, mask: 255.255.255.0, gw: 192.168.4.1)
    dhcp server start:(ip: 192.168.4.1, mask: 255.255.255.0, gw: 192.168.4.1)
    mode : sta(24:0a:c4:00:12:c0)
    n:1 0, o:6 0, ap:255 255, sta:1 0, prof:6
    state: 0 -> 2 (b0)
    state: 2 -> 3 (0)
    state: 3 -> 5 (10)
    add 0
    
    connected with goofy, channel 1
    ('192.168.0.118', '255.255.255.0', '192.168.0.1', '192.168.0.1')
    MicroPython d78a5a3 on 2016-11-05; LoPy with ESP32
    Type "help()" for more information.
    >>>
    

  • Global Moderator

    @MainSheet Can you check with putty in serial mode? Set connection type to Serial, adjust the Serial line COM port number and set a speed of 115200. Make sure PyMakr is closed and click Open

    alt text

    Then press the reset button on the WiPy2/LoPy and post the output you get.

    When you post the output please surround it with ``` before and after the output.



  • @Xykon most of the time I get this, :

    Connecting to a Pycom device...
    Error while communicating with the Pycom device! (click to attempt to reconnect)
    Connecting to a Pycom device...
    Error while communicating with the Pycom device! (click to attempt to reconnect)
    Connecting to a Pycom device...
    Error while communicating with the Pycom device! (click to attempt to reconnect)

    Occasionally there will be a normal connection in between but it only stays up for a few seconds.

    few other details
    Tried PyMakr in Windows10 and Ubuntu .
    can't connect with Putty or Filezilla.
    PyMakr is 1.0.0.b6

    Thanks for the help
    Steve


  • Global Moderator

    @MainSheet Can you post the output you get on the serial port?



  • Hi,

    I just updated 2 LoPy's to 0.9.3.b2. After updating I have not been able to communicate with either using telnet, ftp or PyMakr .
    I tried all 3 safe boot modes on both devices, no luck. Every once and a while I will get a >>> prompt but within seconds I get a connection error.

    Otherwise, they seem to be working, both a updateable, heart beat led is working and when in safe boot mode they both come up as APs, and I can get a connection to them when they are in AP mode.



  • Hi all great work you guys are doing i have 2 LOPY's which i have updated and have running with a fixed IP attached to my AP at home i'm running on a MBP on macos 10.12.2 and when i downloaded the current updater it will not open, i get the PY icon for about a second and then it disappears.

    Any help would be great thanks.

    Dale.



  • New firmware

    >>> os.uname()
    (sysname='WiPy', nodename='WiPy', release='0.9.3.b2', version='d78a5a3 on 2016-11-05', machine='WiPy with ESP32')
    >>> 
    

    Still can not connect to WiPy2 from Pymakr by COM port

    ets Jun  8 2016 00:22:57
    
    rst:0x1 (POWERON_RESET),boot:0x13 (SPI_FAST_FLASH_BOOT)
    ets Jun  8 2016 00:22:57
    
    rst:0x10 (RTCWDT_RTC_RESET),boot:0x13 (SPI_FAST_FLASH_BOOT)
    configsip: 0, SPIWP:0x00
    clk_drv:0x00,q_drv:0x00,d_drv:0x00,cs0_drv:0x00,hd_drv:0x00,wp_drv:0x00
    mode:QIO, clock div:2
    load:0x3fff9010,len:8
    load:0x3fff9018,len:312
    load:0x40078000,len:2348
    ho 0 tail 12 room 4
    load:0x4009f000,len:1364
    entry 0x4009f2f8
    rtc v112 Sep 26 2016 22:32:10
    XTAL 40M
    frc2_timer_task_hdl:3ffd9898, prio:22, stack:2048
    tcpip_task_hdlxxx : 3ffde064, prio:18,stack:2048
    phy_version: 123, Sep 13 2016, 20:01:58, 0
    pp_task_hdl : 3ffdf8b0, prio:23, stack:8192
    mode : softAP(24:0a:c4:00:a8:bf)
    dhcp server start:(ip: 192.168.4.1, mask: 255.255.255.0, gw: 192.168.4.1)
    dhcp server start:(ip: 192.168.4.1, mask: 255.255.255.0, gw: 192.168.4.1)
    MicroPython d78a5a3 on 2016-11-05; WiPy with ESP32
    Type "help()" for more information.
    >>> 
    

Log in to reply
 

Looks like your connection to Pycom Forum was lost, please wait while we try to reconnect.