Failed to connect (Port is not open)



  • Currently try to run the coding for the pytrack but when connect the pytrack it show error.

    0_1507775962117_error.JPG

    Before this i have update the firmware with everything done and replace the "COM6" on the global setting. However, after few days i try to connect the pytrack it show the error. May i know how to fix it?



  • @crumble Thank you for your explanation.
    I have another question, i have downloaded the libraries from github.com and currently i am running for the pytrack with lopy for the latitude and longitude data. May i know is it correct to download the .py files (L76GNSS.py, LIS2HH12.py, pytrack.py) and navigate the file to a new folder eg: pytrack lib and in the Atom with pymakr plugin i click on File and Add new folder and select the pytrack lib folder.

    0_1508746964056_392c211d-4ce6-4774-b461-aed4aa8664cb-image.png

    may i know when i upload the libraries to the pytrack board by "sync folder" or "sync file" it showing the error since the "main folder" is too big. What is the correct way to upload the libraries ?



  • @mj it depends. The >>> the prompt. The LoPy does not know if someone is connected to the UART. It sends the prompt as soon as it is ready for input. Then it is waiting for input. If your PC connects after the LoPy has send the prompt, you will see nothing unless you send the lopy something too evalute. A \n for example.

    The blinking cursor is handled by your terminal and not by the LoPy. It will not send you any data while it is waiting for input and no background task is running. So it can look like their are not connected. Especially if you have not configured your IDE to send a ctrl-c when it connects.



  • @crumble Hi, i have a doubt since i have connected my pytrack but under REPL console, it do not show the sign of ">>>" is it ok for it?



  • @crumble It really works for your method. Finally, it works and connected in atom. Thank you very much since i have pending this problem for weeks.

    0_1508150765710_connected.JPG



  • @mj you still need admin rights. If you user has local admin rights, you shall be able to install it. If you computer is in a domain, you have to ask your admins. They may have restricted your local admin rights. If not try to install it as administrator. If this does not help, google "windows security settings install unsigned driver" and follow the steps for your operating system.



  • @crumble The file is already an inf file. And i right click to install it still showing that INF does not contain the digital signature information.

    0_1508148071342_inf error.JPG



  • @mj rename pycom.inf.txt to pycom.inf . Right click and choose install.



  • @crumble the driver from https://docs.pycom.io/chapter/pytrackpysense/installation/drivers.html is only the notepad after i downloaded it. It is not a zip file. How can i get the driver folder?

    0_1508143628173_pycom properties.JPG



  • Please try to install the driver with administrator rights.The driver is not signed by someone whicht the OS trust. If you have the rights, you can tell the system that you trust the driver.



  • @crumble Hi, i have uninstall the pytrack from the device manager and plugin in again it show under "other devices" as shown below.

    0_1507998184566_pytrack devices.JPG

    I followed the link in https://docs.pycom.io/chapter/pytrackpysense/installation/drivers.html although my windows is windows 8 not windows 7. But when i update the driver i encounter this showing that the third party does not contain the INF digital signature information.

    0_1507998279819_1510.JPG

    How can solve this problem?



  • @mj this worked on my machine. Have you cecked that files shall be removed when uninstalling the driver?

    Version 0.0.6 is linked in the Announcement section of the forum. The docu still shows 0.0.4 as the latest. 0.0.6 fixed the wake-up from deepsleep reason.

    I Stuck now on upgrading the firmware of the LoPy on the PyTrack. Last time, I Pluged it on a ExpansionBoard. This time I soldered a switch on the LoPy. As a resut it fails allways with connection problems :-/



  • @crumble According to the pycom.io documentation, the latest Pytrack dfu is version 0.0.4. So far, I had tried to uninstall driver ans scan again it still under libusbK. Not showing COM.



  • @mj My PyTrack is now nón 0.0.6 as well. While libusK is installed, Windows 7 detects it as a libusK device for some seconds. You have to be quick again.

    • Open the device manager,
    • Plugin the pytrack. It will be listed as a libusK device not as com
    • right click on pytrack
    • select deinstall driver, hook uninstall driver
    • rescan devices
    • pytrack will become a com device


  • @mj I understand that @crumble suggests to deinstall the dfu driver on that USB device (and maybe otehr drivers too) and reinstall the COM-VCP driver again. That sounds reasonable.



  • @crumble I have installed the dfu driver in the pycom.documentation yesterday and update the Pytrack, I also ensure that the Pytrack is in DFU mode as well. The problem is still there.
    I have tried my Pytrack on my friends laptop since she only using Lopy and expansion board only. My Pytrack works on her laptop as normal but when I tried it on my laptop it stated zero serial board. I have no problem for my expansion board too only Pytrack goes wrong. This make me feel confuse and I have no idea what happen to my Pytrack.

    Today's dfu driver is it the latest?



  • @robert-hh I have downloaded the driver and follow the step inside the link but still showing the same problem.



  • Have you updated the firmware of the pytrack?

    After that mine was not detected as a com device. You are using windows, right? Please check in the device manager, if your pytrack ist detected as a com or a dfu device. I can't remember how i fixed this. I guess I deinstalled the dfu driver, so that the pytrack was detected as a com device again.

    Install todays pytrack firmware, before you do this ;)



  • @mj Do not use the driver method, download the driver file and execute that manually.



  • @crumble i have try to install the driver and follow the step given. But when i install the driver it showing the driver is already update.

    0_1507858090340_update.JPG

    I try connect the pytrack in atom it stills showing the "Found 0 serial port"

    0_1507858159552_0 serial por.JPG

    May i know how to get it fix ?


 

Pycom on Twitter