REPL on MAC term frozen, no input taken



  • Hi all,

    just updated all my WiPy2 and LoPy devices that I've not touched in a while and after the update was done successully and wire etc removed, I plugged them n and tried to connect via serial .

    I see a serial device and connect via

    screen /dev/tty.usbmodemXXXX 115200

    -- nothign happens --- when I press the reset button, I see this:

    ets Jun 8 2016 00:22:57

    rst:0x1 (POWERON_RESET),boot:0x13 (SPI_FAST_FLASH_BOOT)
    ets Jun 8 2016 00:22:57

    rst:0x10 (RTCWDT_RTC_RESET),boot:0x13 (SPI_FAST_FLASH_BOOT)
    configsip: 0, SPIWP:0xee
    clk_drv:0x00,q_drv:0x00,d_drv:0x00,cs0_drv:0x00,hd_drv:0x00,wp_drv:0x00
    mode:DIO, clock div:1
    load:0x3fff9028,len:8
    load:0x3fff9030,len:932
    load:0x4009fa00,len:0
    ho 12 tail 0 room 4
    load:0x4009fa00,len:13232
    entry 0x400a04e8
    MicroPython v1.8.6-820-g56004e13 on 2017-11-08; WiPy with ESP32
    Type "help()" for more information.

    Looks cool, but no input from the keyboard is accepted. I cannot type :-) Is this an issue on mac only? Any fix?



  • @hansamann said in REPL on MAC term frozen, no input taken:

    I just wanted to say this worked for me with a WiPy 2.0. I was running the latest firmware and my serial REPL was frozen but I could telnet/ftp to the wipy just fine. I did as the previous poster said, I first erased the flash and then ran the updater again to reload the firmware and now the REPL is working again over USB. Here's my system info.

    import os
    os.uname()
    (sysname='WiPy', nodename='WiPy', release='1.10.1.b1', version='v1.8.6-839-g536c958c on 2017-11-1)



  • This post is deleted!


  • @hansamann Erase the flash & reload the firmware, with:

    pip3 install esptool
    esptool.py --port <your com device> --baud 230400 --chip esp32 erase_flash

    For flash erase, you too have to connecte G23 to GND and pusg reset.
    Erasing flash and reload should always work, as long as the device is not physically damaged.


 

Pycom on Twitter