New firmware release v1.11.0.b1 and new updater tool version v1.1.4.b1 (FiPy and GPy support)

  • @xykon The code I updated before works with the one of the last firmware versions. Uses the Pycom booting with wifi and Lora, and the Lora Raw example.

  • @xykon using Win10 with VS Code and Pymakr extension.

  • administrators

    @ledbelly2142 Can you please confirm the OS you are using? I can send you the instructions necessary to completely erase your device and (optionally) dump the current flash memory so we can try to replicate the issue to hopefully find a more permanent solution?

  • @daniel I have also attempted to reinstall the firmware update with slow and fast connection. Firmware update appears to connect to the device and confirm update. I can update the firmware from the update utility. It's not totally bricked. Just hangs on reset/reboot.

  • @daniel Yes, the LED is blinking orange. Using the factory reset documented HERE should have removed any existing code. Please correct me if I'm wront. Used the final 1.5 second window to reset factory firmware.

    I have tried safe boot a number of times on both LoPys I attempted to update. Reset/Reboot hangs.
    What can I try next?

  • @ledbelly2142 is the LED blinking in orange when you try a safe boot? Are you sure the device is not running any code?

  • Downloaded the new updater and attempted to update a LoPy with expansion board. After update, LoPy does not completely boot. LoPy hangs on reset:

    rst:0x1 (POWERON_RESET),boot:0x13 (SPI_FAST_FLASH_BOOT)
    ets Jun  8 2016 00:22:57
    rst:0x10 (RTCWDT_RTC_RESET),boot:0x13 (SPI_FAST_FLASH_BOOT)
    configsip: 0, SPIWP:0xee
    mode:DIO, clock div:1
    ho 12 tail 0 room 4
    entry 0x400a0644

    Bricked 2 LoPys this way, attempted firmware reset with 3.3V pin and P12 with no effect. Safeboot does not work.

  • Tried to do this update on a new FIPY for ~60 mins with no success. It would fail at 15% every time.

    Out of desperation I tried a different USB cable... and it worked first time. Never had an issue with the original cable before, it's been used for years on dozens of devices. New cable is Belkin branded. Just something else you can try if you're having issues. Heh, Pournelle's law!

  • @xykon
    Thanks, now the link works for LoPy 915 Mhz.

  • administrators

    @rcolistete We changed the way the firmware images are generated which caused the firmware file for the LoPy 915 MHz version to have a slightly different filename. While the firmware update tool would still pick up the correct filename from the database, I have updated this manually now so that the above link works as well.

  • What is the v1.11.0.b1 firmware file link for LoPy 915 MHz ? The link "" doesn't work (showing "Unauthorized" error message).
    For LoPy 868 MHz it is "" and works. For WiPy 2, the link "" is also working.

  • administrators

    In order to upgrade your board using a Pytrack or Pysense and using the dialog based command line UNIX / Linux update tool, please use the following workaround:

    In this example it is assumed your Pytrack / Pysense is /dev/ttyACM0

    From the pyupgrade directory, run:

    python bin/ -p /dev/ttyACM0 --enter
    python bin/ -p /dev/ttyACM0 --exit

    You might also need to disable the ModemManager service in Ubuntu before running the upgrade

    sudo service ModemManager stop
    python bin/ -p /dev/ttyACM0 --enter
    python bin/ -p /dev/ttyACM0 --exit
    sudo service ModemManager start

    The updater assumes that your user has access to the "dialout" group. If this isn't the case please run:

    sudo usermod -a -G dialout $USER

    After this change you need to logout or reboot your PC!

    I will update the cli version to run this automatically in the next few days. I'm also planning to release Debian/Ubuntu packages for both the cli and gui version that installs all necessary dependencies and include udev rules to avoid conflicts with ModemManager.

Log in to reply

Pycom on Twitter