New firmware release v1.13.0.b1 (Sigfox and LoRa coexistency on the LoPy4)


  • administrators

    Hello,

    This release is mainly about support for the LoPy4. The change log is as follows:

    • esp32: Add LoPy4 support with LoRa and Sigfox on the SX1276
    • esp32: Save the downlink ack flag as part of the LoRaWAN NVRAM parameters.
    • esp32: Only bootstrap the 32KHz RTC clock if enabled with an external crystal. Solves GPIO issues when using both P19 and P20.
    • esp32: Fix os.uname() crash on the FiPy.

    Cheers,
    Daniel



  • @daniel @Xykon I also updated to the latest version but sigfox is not working. Do you have any idea what could be the reason? Is it bricked?



  • Also, in the device information at Sigfox backend "Radio Configurations" seems wrong. ( I am in Japan):

    Modem manufacturer: PYCOM_device_maker
    Modem name: SiPy-14
    Modem version: S I P Y 1.0 R
    Radio Configurations: RC1



  • Thanks @livius, just downgraded to 1.12.0.b1 using the same link you provided. @daniel it is still same, no message is going to sigfox backend.
    Can be it antenna issue?





  • @denial How can I revert back to 1.12.0.b1 ? I guess the updater always installs the latest one.


  • administrators

    @pymiom 1.12.0.b1 also has Sigfox. Have you tried a different USB cable? There are a lot of weird issues which are caused by faulty cables...



  • @daniel do you have any ideas about the reboots of the fipy? I still have yet to downgrade, but need the Sigfox functionally and concerned it may not be in the version I downgrade to.

    Cheers!


  • administrators

    @naveen seems correct. Are you able to revert the firmware back to the previous release? As far as we can test Sigfox is still working OK with this version, but maybe in your case there's a problem. It would be great if you can revert to the 1.12.0.b1 release and test again. Thanks.

    Cheers,
    Daniel



  • '@daniel I got this output:


  • administrators

    Hello Naveen,

    The only way to know if the device is transmitting is with a Spectrum Analyzer, but I don't think you could have damaged the radio. Please read the Sigfox ID and PAC from the device and tell me what you get:

    from network import Sigfox
    import socket
    import binascii
    
    sigfox = Sigfox(mode=Sigfox.SIGFOX, rcz=Sigfox.RCZ3)
    
    print(binascii.hexlify(sigfox.id()))
    
    print(binascii.hexlify(sigfox.pac()))
    

    Cheers,
    Daniel



  • @daniel As you suggested, I clicked on the "Disengage the sequence number" option for the registered FiPy device in the SigFox backend but the FiPy still does not send message.
    How can I know if the SigFox chip is okay and working? Is there any way to debug whether the messages are being sent?


  • administrators

    @xykon said:

    UPDATE: During internal testing I discovered a bug where, when you try to update/register more than one Sigfox device for the first time using the restart button, the download seems to take forever when updating the second device. I will upload a bugfix for this as soon as possible.

    A bugfix for this is now available as a beta release for MacOS, Windows and Linux


  • administrators

    @naveen please go to the Sigfox back-end portal, click on your device (the FiPy in question) and, find the option to "Disengage the sequence number" and click on it. The try sending messages again. The failed update might have messed up the NVM of the device causing a a corruption of the sequence numbers.



  • I tried with another USB cable which I used before and it worked! But the other problem is still there, fipy is not sending message to sigfox anymore. Why?



  • @Xykon I do not use any expansion board. I use usb serial adapter with breadboard (in fact, I made one using mkr1000). I have updated last firmware twice (few days ago) using this setup successfully. All wires are connected correctly and I always hit reset button before upgrade. Nothing is connected to FiPy except TX/RX, VIN/GND (with GND and G23 connected using jumper). Also, when I run "screen" command on MacOs and hit reset button it says "Waiting for download...", so I think serial connection is working. I guess for some reason it is not able to read memory. I am not able to erase firmware using esptool, too. Otherwise everything is working with the existing firmware (the last one). I also tried to do safe boot by connecting P12 to 3v3 with all possible ways but the firmware stays same. And the main thing is SigFox stopped sending messages, before I was able to send 21 messages so far and I believe Sigfox coverage is pretty good where I live (near Tokyo).


  • administrators

    @naveen Do you use a Pytrack / Pysense or Expansion Board 2.0?

    The most important thing is to make sure that no other program is using the serial port when you try the firmware upgrade. Unfortunately I don't have a way of checking this in the app.

    For Pytrack / Pysense: Please make sure you have the latest firmware loaded.

    For Expansion Board2: Please make sure you press the reset button before every use of the firmware update or esp-tool. Can you please post the output you see on the serial port when pressing the reset button with the firmware jumper wire attached?



  • I am not able to update using the GUI updater for MacOS. It always fails.

    I tried to update using pycom-fwtool-cli but I am getting following error message:
    Connecting.....
    Uploading stub...
    Exception: read failed: [Errno 6] Device not configured, on line 197

    Then I tried esptool.py read_mac and it says:
    A fatal error occurred: Failed to read target memory

    The FiPy's BLE and Wifi still works but now it stops sending message to SigFox (before it worked very well). I am not sure if it is related to the update failure.

    UPDATE: I also updated esptool to the latest version and run "esptool.py read_mac" but it stucks at "Uploading stub..." :
    esptool.py v2.2
    Connecting....
    Detecting chip type... ESP32
    Chip is ESP32D0WDQ6 (revision 1)
    Uploading stub...



  • HI,

    I am trying the new code, but my FiPy is constantly rebooting with trace errors. I have tried to update/change the firmware on both Windows and Mac, but having the same issue once I have had sucess..

    Here's the output from the logs:

    https://www.dropbox.com/s/jf0udt2o5isbowk/trace.txt?dl=0

    I had to revert to using a USB CP2102 module as I couldn't get the tool to work with a PyTrack Module and the two PINs connected.

    Is there a way I can flash an older version of code just to rule out the device? Also, is there a way to "reset" the firmware updater software as it could have been that I selected the wrong board when updating.

    Thanks!



  • This post is deleted!

Log in to reply
 

Pycom on Twitter

Looks like your connection to Pycom Forum was lost, please wait while we try to reconnect.