FiPy + Extension Board Power consumption

  • Hi,
    maybe I'm wrong but i thought that with the latest firmware it ( 1.15.01.b ) also for FiPy we can reach the ultra low power mode. Powering my expansion board with a Fipy mounted, with power from battery, during deepsleep i'm consuming 206 ma.
    Those the main line of code during each power cycle regarding to reduce the power consumption: -> pycom.wifi_on_boot(False); -> pycom.heartbeat(False); -> machine.pin_deepsleep_wakeup(['P8','P10'],1,True); -> machine.deepsleep(900*1000).

    Most strange is after a reset ( with reset button ) during the current goes down to 70 ma, in the rise to 180 ma, and during deepsleep aroung 206 ma.

    Other times, after some manual reset ( same program running ) during deepsleep i reach 35 ma and during program execution 80-90 ma. A few reboot later, FiPy drain again 200 ma.

    Is there a line guide to enable the deepsleep mode correctly ( i.e. wifi_on_boot(false),, lte.deinit() OR maybe ariplane mode?, sigfox.send and the sigfox.deinit() )?

    Thanks, Andrea.

  • Hi,
    RTS and CTS remove ( also the LED one ). Performed a couple of reset, the deep mode still consume 70-80 ma. During wake up it rise to 240 ma, 80 - 84 ma during boot and main.
    Does the sigfox init library routine ( or socket ) without send anything cause power drain? Do you suggest to init LTE modem and then deinit? ( Anyway if you write in the insert LTE.init() and LTE.deinit() one after the other, Fipy stuck you need to remove the lines above, maybe a small delay can help. )

  • administrators


    Since you are using a regular expansion board, the flow control lines can interfere with the communication between the FiPy and the cellular modem. Can you remove the RTS and CTS jumpers on expansion board and run your tests again?

Log in to reply

Pycom on Twitter

Looks like your connection to Pycom Forum was lost, please wait while we try to reconnect.