Pymakr 1.2.8 - Can't find upload button or global settings

  • I just updated from Pymakr 1.2.7 to 1.2.8. But I can't find the upload button so I can upload my code to my LoPy. Where do I go in order to find it?

    I would also like to know if there's a global setting option where you can change COM port, just like I could in 1.2.7.

  • @seb
    Yes, I do get the led to blink orange. That has not been an issue at all, works fine.
    I tried uploading my code and keeping 3.3v and G28 connected, and the result was this:
    0_1520259525328_Safe-boot error.PNG

    I tried removing the wire connecting 3.3v and G28 and I could finally upload!
    Thanks for all the help!

  • administrators

    Hmmm, thats very curious. I'll report it to the pymakr team.

    In the meantime, on the expansion board P12 is labeled G28 (bottom left most pin). When this is connected to 3.3v and you press the reset button, do you see the on-board LED blink orange?

  • administrators

    This message suggests that you module is not on version 1.17.0.b1 of the firmware, can you run the following on the module, and post the output:

    import os

  • @seb
    I get this error when I have it enabled:
    And this when I have it disabled:

    I tried manually doing a reset and it did not help. I didn't have P12 on my expansion board, so I connected it to G20

    I can send over my code to your E-mail.

  • administrators

    What error do you recieve with safe-boot enabled? also can you share your code so I can try replicate the issue.

    Try manually doing a safe boot by connecting P12 to 3.3v and pressing the reset button, you will see the onboard LED blink orange. After this does the upload succeed?

  • @seb

    When I press the reset button it does print out messages. So the communication between pymakr and the LoPy does work. In the lopy I have a code running for BLE communication, for a simple test I had a while loop that sent a value and increased it by 1.

    I also went back to the global settings and enabled the safe-boot option, but it did not solve anything since I've already tried doing so before.

    I had pymakr 1.2.7 on a backup computer and ran the same code I wanted to upload and it worked just fine. Then I tried uploading on my work computer that has 1.2.8 it didn't work, it still gave out the same error.

  • administrators


    Can you please open the terminal, then press the reset button on your module. Do you see any messages appear? If you do this means the communication between pymakr and your module is working. It might be that there is code running on the module that is preventing you from uploading successfully. If you have already upgraded to 1.17.0.b1 can you please enable the safe-boot option in global settings and see if that fixes it?

  • @seb Thank you for the quick replies!

    I did as you said and updated the firmware to the latest version, but sadly that did not solve my issue with the safe-boot. I still encounter the same errors as I mentioned before.
    0_1520245113544_Error 1.PNG
    0_1520245123983_Error 2.PNG

  • administrators

    The latest version of Pymakr on atom does a safe-boot ( and do not run) of the module before uploading code, this is to avoid any issues such as running out of RAM due to code running on the module. In order to make use of this functionality, the module must be upgraded to firmware 1.17.0.b1 (current version at the time of writing) or higher. Please try a firmware update of your module and let me know if it works again.

  • @seb I'm using Atom

    I got it to work after uninstalling and installing pymakr again. It looks the same just like in 1.2.7

    But now I can't upload because it complains that "Not safe booting, disabled in settings"
    And when I enable it in global settings I get "Safe boot not available for this version ()"

    What does that mean and what do I need to do?

  • administrators

    To clarify are you using Visual studio or Atom

Log in to reply

Pycom on Twitter

Looks like your connection to Pycom Forum was lost, please wait while we try to reconnect.