Problem to connect after wrong update



  • Hi everybody!
    I was trying to update the firmware of my L01 OEM. The configuration is L01 on OEM reference board plugged onto expansion board 2.0. I have another one that work perfectly. Also this one worked good (tried the telnet connection) before the battery of my laptop went down during firmware upgrade.
    Now what I get when connecting by serial to the expansion board is just one ">" instead of ">>>". What can I do to get back to factory condition?
    Thanks in advance



  • @gugu

    Thats correct, you can reset the OEM modules by pulling the RST pin LOW. The OEM reference board you have the module soldered to should also also have a reset button near the RGB LED



  • Great! Thanks a lot seb! I was having some trouble understanding how to reset the device without having the reset button. It just needed to put the RST pin to ground. Thanks again!



  • Hi,

    If you connect 'P2' to 'GND' while powering/resetting your module it will enter a download mode (you should see this appear on the serial terminal). If you see the message "waiting for download" you can then use the standard pycom firmware upgrade tool to restore the firmware to the device. Be sure to close your serial terminal first though as this will interfere with the flashing.


Log in to reply
 

Pycom on Twitter

Looks like your connection to Pycom Forum was lost, please wait while we try to reconnect.