Lopy firmware and other problems

  • Hi everyone.
    I hope someone could help me because i am very lost with this.
    I have two Lopy4 for developing with two expansion boards. I have been using one until yesterday. I made my own program that works ok, with deepsleep, wlan, sigfox and ble, separately not simultaneously. But suddenly lopy stops to work and start to overheat.
    Because I want to descart circuit issues independent from the lopy, i started to use the second lopy, for this i use the pycom firmware update, i connect the lopy to PC by atom and I see that it works but few minutes later, it start to give "Guru Meditation Error" in Core 0 and in Core 1.
    I have tryed upgrading again, with other expansionboard, with another usb wire and all give me the same result, error in cores and the core dumb start.
    The other lopy is died, atom detects it when i connect by expansion board, but the lopy don´t give any response nor the RGB led blinks. I don´t remember wich firmware it have, i updated it at least one month ago.
    What can i do with this two guys???
    Any help, please.

  • administrators

    @elenah Can you please try pycom-fwtool-cli --port COM3 --speed 115200 --verbose wmac

    It seems to be able to upload the "stub" now which is the 2nd stage bootloader. However it seems to have issues switching to 921600bps after that. Using 115200 would skip this step.

  • @xykon I have tried again today with the tool and today it answer this:

    c:\Program Files (x86)\Pycom\Pycom Firmware Update>pycom-fwtool-cli --port COM3 --verbose wmac
    Running in FTDI mode
    Uploading stub...
    Running stub...
    Stub running...
    Changing baud rate to 921600
    Exception: Timed out waiting for packet header, on line 406

    Can I do something with this?

  • @robert-hh Only one blinks, the one that don´t level down the input entry, i think the other one is completely dead.
    When they get hot is level -it hurt when you thouch it by chance...
    But forget it, it has stop to blink again even with external input. I´m really tired, every module we have buy have work worst and worst.
    We start with sipy and it "false" deep sleep and now this, the module that works whenever it wants. Really bad experience, lot of headaches and completely useless stock for our company.

  • @elenah
    a) Do both units at least blink, when you supply them by an external source? If you have a blue heartbeat, then they are working fine.
    b) When you power through an external supply, can you measure the current they draw?
    Also - about hot: hot means typically - too hot to touch. The power consumption is at least 1W. That will warm up the device noticably, but not uncomfortable.

  • @seb Yes, are the same two expansion boards, i one have this two.

  • @robert-hh I have reset the computer and it do the sime, but i have noticed that if i power the lopy by an external continuous 5V input it at least blink, i can´t see if it gives the core 0 or 1 error.
    The part i feel that first get hot is in the other side, next to wifi/BT antenna connector. It´s a lopy4

  • administrators

    @ElenaH, are you using the same expansion board you previously had similar issues with? (https://forum.pycom.io/topic/1725/sipy-doesn-t-work-anymore)

  • @elenah 0.48V sounds bad, 4.88 V is fine. In my experinece. if you connect a device to USB which dfraw a too high current, that port is switched off. Only a computer reset will bring that back to operation again.
    When you say, that a device gets hot, is it a specific component on the device, like the regulator? The regulator is a small chip close to he RGB LED.

  • administrators

    It sounds like the voltage regulator has been damaged on one of them. Have you at any point connected the module backwards or maybe plugged it in off-set by a few pins?

  • @robert-hh Without lopy both: expansion board have 5V between Vin and GND.
    With lopy: one of the lopy gives 0.48V between Vin and GND, the other one gives arround 4.88V

  • @elenah Can you measure the input voltage between Vin and GND at you lopy modules? It should be about 5V.

  • @robert-hh usb 3.0 in windows 10 Pro. Since two days ago everything works ok, i haven´t change anything on the computer.
    Tell me if you need more information about, i don´t know what information exactly you want to know.

  • @elenah What kind of computer and USB port are they connected to?

  • @xykon I do it with the wire, without it, pressing reset, not pressing it. All ways possible.
    I haven´t do anything new on the lopys and the one that blinks yesterday today it doesn´t do it. All it do is show dumb in the serial console.
    Everyday it go worst and worst, i think that both of them are "really cool" stones on my desk, anything more, oh! and they overheat when i connect it so they become "really hot" stones. Very funny all this :(

  • administrators

    @elenah Did you install the jumper wire between P2/GND? Did you press the reset button on the module next to the RGB LED before running each command?

  • @xykon I have done what you told me and i have this answer for both lopy:

    c:\Program Files (x86)\Pycom\Pycom Firmware Update>pycom-fwtool-cli list
    COM3 [USB Serial Port (COM3)] [FTDIBUS\VID_0403+PID_6015+DO0034RTA\0000]
    COM1 [Puerto de comunicaciones (COM1)] [ACPI\PNP0501\0]

    c:\Program Files (x86)\Pycom\Pycom Firmware Update>pycom-fwtool-cli --port COM3 --verbose wmac
    Running in FTDI mode
    Exception: Failed to connect to ESP32: Timed out waiting for packet header, on line 397

    c:\Program Files (x86)\Pycom\Pycom Firmware Update>pycom-fwtool-cli list
    COM4 [USB Serial Port (COM4)] [FTDIBUS\VID_0403+PID_6015+DO0037MHA\0000]
    COM1 [Puerto de comunicaciones (COM1)] [ACPI\PNP0501\0]

    c:\Program Files (x86)\Pycom\Pycom Firmware Update>pycom-fwtool-cli --port COM4 --verbose wmac
    Running in FTDI mode
    Exception: Failed to connect to ESP32: Timed out waiting for packet header, on line 397

    Tell me if I am doing something wrong.
    Thanks for all your help anyway.

  • administrators

    @elenah Can you please try the CLI firmware update tool ?

    Please use the following options (you can get the list of com ports by using the list option):

    First check if communication is possible
    pycom-fwtool-cli --port COM_PORT --verbose wmac

    If the first command is successful, please try this one (this command may take up to 30 seconds):
    pycom-fwtool-cli --port COM_PORT --verbose erase_fs

    If you get any error messages from the tool please post them here.

  • @seb Yes, i have choose 115200
    (i can´t answer before because i haven´t got 3 reputation)

  • administrators

    @elenah with baud 115200 yes?

Log in to reply

Pycom on Twitter

Looks like your connection to Pycom Forum was lost, please wait while we try to reconnect.