Can reliably hang GPY on expansion board with the following



  • Hi

    I have a GPY on expansion board 2.
    Have been trying unsuccessfully since last week to get LTE running ;-) Have tried everything outlined in various form posts and have contributed to that discussion ;-(

    Just upgraded to latest firmware and have found a repeatable hang on the system necessitating a hard reset.

      (sysname='GPy', nodename='GPy', release='1.17.2.b1', version='v1.8.6-849-1bf377b on 2018-03-16', machine='GPy with  ESP32')
    

    Essentially the problem repeatable by performing the following steps.

    from network import LTE
    lte = LTE()
    lte.send_at_cmd('AT+COPS=?')   # ineteract with the modem via send_at_cmd
    import time
    

    At this point the system will hang until a reset.

    Crtl-C won't interrupt nor any other sequences sent through the console.



  • @seb Problem ceased with the latest firmware.



  • @timh @seb

    My GPY hangs when i call lte = LTE(). I'm stuck with this for weeks already, even on 1.17.3.b1.



  • @seb Yes. I am only interested in CAT-M1 and have confirmed with Telstra they are for CAT-M1 (see discussions re: telstra).
    Irrespective I don't believe the system should hand when importing time module.

    Any send_at_cmd performed before importing time will hang the current firmware.

    Have you tried it ?

    Thanks

    T



  • Are you trying to connect to regular LTE? Our modules only support LTE CAT-M1 and NB-IoT, these a lower power protocols that differ from regular LTE.


 

Pycom on Twitter