lte = LTE() reboot after FW update 1.17.2.b1



  • Hi,
    by REPL console, sending just:

    from network import LTE
    lte = LTE()

    cause the reboot of FiPy.

    /Users/catalin/esp/pycom-esp-idf/components/freertos/./queue.c:718 (xQueueGenericSend)- assert failed!
    abort() was called at PC 0x4008b65c on core 1

    Backtrace: 0x4008ec13:0x3ffdb9c0 0x4008ec44:0x3ffdb9e0 0x4008b65c:0x3ffdba00 0x40102d0d:0x3ffdba40 0x40103163:0x3ffdba60 0x40103188:0x3ffdbb00 0x401036c6:0x3ffdbb20 0x401037fd:0x3ffdbbc0 0x400f921b:0x3ffdbc00 0x400f178d:0x3ffdbc20 0x400fcb07:0x3ffdbc40 0x400f4e8c:0x3ffdbce0 0x400f178d:0x3ffdbd50 0x400f17ba:0x3ffdbd70 0x400de2ab:0x3ffdbd90 0x400de548:0x3ffdbe30 0x400dd2e9:0x3ffdbe70

    ================= CORE DUMP START =================

    ...................
    ..................
    ..................

    ================= CORE DUMP END =================
    Rebooting...
    ets Jun 8 2016 00:22:57

    rst:0xc (SW_CPU_RESET),boot:0x12 (SPI_FAST_FLASH_BOOT)

    os.uname()
    (sysname='FiPy', nodename='FiPy', release='1.17.2.b1', version='v1.8.6-849-1bf377b on 2018-03-16', machine='FiPy with ESP32', lorawan='1.0.2', sigfox='1.0.1')

    Any idea? Best regards, Andrea.



  • @administrators @jmarcelino
    I have two Fipy’s one installed on a Pytrack board and another on an Expansion Board 2.0. I did a firmware upgrade on the the first Fipy on Expansion 2.0, the whole process never worked and went into safe recovery after multiple tries( with AT+SMSWBOOT=3,0, failed error). Now I have an
    error code for at command ‘ATI’ on that FIPY.
    So I have refrained from firmware update on the other FiPy on Pytrack . Now on the FiPy on Pytrack which was not updated ( firmware) it is still responding to lte=LTE(), followed by LTE(‘ATI’), but I get AT+CSQ as 99,99. And on the same FiPy if I do AT+ CGSN, I can get the modem IMEI number but AT+ CCID it does not return the SIM number. It makes me conclude that the SIM and the modem is not talking to each other or exchanging data. Should the system not respond to standard AT command even without firmware upgrade???
    My fiest FIPy is already not usable but I don’t want to do the same to the other.
    I am using two Cat-M1 SIM from Verizon and per one of the suggestions from @jmarcelino , I have already setup a ticket with you tech team.
    Hope to find a resolution soon! Thank you much for the assistance.



  • Hi Livius,
    thanks it worked!
    Andrea




 

Pycom on Twitter