Atom fails to use USB port. LoPy via PyTrack



  • Hi,

    Rank beginner question.

    I am following the setup procedures for the LoPy. I've downloaded Atom, installed Pymakr. I copied the USB port name using More/Get Serial Ports

    I pasted that name into the Settings/Global settings/Device address

    But Atom still tries to connect using 192.168.4.1

    I rebooted, same thing.
    I even tried putting the usb port name into the Settings/Project settings/Address field, reboot, still no good.

    What am I doing wrong?

    Thanks for your help.



  • @seb

    Every time I restated atom it would lose the project directory. I'd have to download pymakr again, then it would work until I stopped atom.

    Turns out the problem was my py directory was moved somehow (I'm sure I did it). When I put it back into the root of my Documents (Mac) folder everything worked again.

    There was a red warning on startup but I missed it.

    Thanks!



  • @seb Wow that was it!

    Thanks so much. I don't think I'd have ever figured this out. No hints in the docs and it seems like Atom just selected .Atom as the project folder.

    But I must have done it.

    Thanks again.



  • @kevin117

    This means pymakr thinks you are working on a project in a folder called .atom. I would recommend you only have one folder, the project folder, open atom and if it still does not detect this you can press the following keyboard shortcut to force atom to re-load:

    • mac: ctrl-alt-cmd-l
    • Windows/Linux: alt-ctrl-r


  • @seb

    says
    Disconnected .atom

    0_1521651682899_Screen Shot 2018-03-21 at 1.00.09 PM.png



  • This post is deleted!


  • @kevin117

    Thats very odd, are you sure pymakr has detected your project properly? It show show like so:

    0_1521626822713_08749052-0bbf-4096-afc1-81f0029579a2-image.png


Log in to reply
 

Pycom on Twitter