[Solved] Charging via Pytrack - very hot / red led without battery



  • Hi!
    I just tried to charge a new LiPo battery via the pytrack board.

    1. After a minute the board becomes very hot, I cannot touch it anymore. The charging LED does not light up.
    2. I removed the battery and when I plugin via USB, the red led now lights up although there is nothing to be charged.
      When I plugin the battery, the LED goes out.

    I checked the polarity of the battery, it seems to be ok.

    Any ideas are appreciated ...



  • @jmarcelino Well, I thought this marking belongs to the LED ... I submitted a trouble ticket suggesting to change the documentation, there is a separate pdf to describe the components of the pytrack/-sense and I really don't get why essential information such as polarity is not included there. Hopefully it gets changed.

    Thanks for your help!



  • @jcaron I bought it from Amazon, it's a Gaoneng 600mAh 3.7V LiPo.
    The polarity can easily be changed, just pull out the contacts and reattach crossed out. The package fits nicely in the IP67 cases pycom provides in the online shop for pytrack/-sense.

    I just measured the power draw, in sleep mode(lopy turned off .. I guess) the damaged board draws 100mA from the battery now :-(
    On the positive side, I still can run half a night of testing and fry some eggs when on USB.



  • There is also a (small) + marking next to the JST connector on the Pysense Pytrack. Perhaps ir could be made larger.



  • @thingomat @daniel Looking at the pictures of the various boards, there is a + marking at the expansion boards, but no indication of the right polarity at PySense and PyTrack. Maybe that can be added to the silk screen.



  • @thingomat Just for reference, what was the source and/or manufacturer/model of the battery?

    I've had similar issue with a small LiPo charger I had bought, which used the opposite polarity. Plug in the battery, instantly smells like something is burning.

    Thankfully it seems the batteries themselves are usually well protected against reversed polarities, as the consequences could possibly be a lot more serious.



  • @jcaron
    Just to conclude this issue:
    Yes, you are right. I checked the polarity of the battery, i.e. red ==+ which was fine.
    Next, I assumed(wrongly) that a connector that is designed to avoid wrong polarity has a standard polarity and if not, that there would be large red indicators with exclamation marks on the PCB as well as the documentation if this is not the case.

    Turns out it is not the case and there is NO documentation. I opened a case in the troubleticket system and will ask for an update of the official documents.

    Bottom line as a reference for readers - no smoke, but the charging IC is dead. It gets really hot (like in: it starts to smell burnt and you cannot touch it for more than a split second ) when it is attached to USB. BUT: he board still works even if I connect the (now correctky poled) battery, in the latter case it doesnt even become hot(less voltage, less current).
    Battery lifetime is miserable even with pytrack sleep, the "charging" LED is on permanently when the battery is connected.

    Good luck and thanks for all responses!



  • @jcaron And never exclude the bad luck that red is not +



  • @thingomat how did you actually check the polarity? It’s not just a matter of checking voltage against the colours of the wires... There’s no standard for polarity on the JST-PH-2 connector, and there are batteries with both polarities.

    Batteries sold for drones and other RC vehicles (I think the connector is often called MMCX or something similar) have the wrong polarity for Pycom devices. Batteries sold by Adafruit for instance have the right one (as far as I know).

    When you look at the connector, with the small center notch up and the wires to the battery towards you, red you be on the left.

    I wonder if the polarity is actually documented somewhere?



  • @robert-hh Thanks for the reply - I checked the battery and it is fine ... there was no smoke and the heat builds up rather slowly, takes 10-20 seconds ..



  • @thingomat I had that once with a charger board. Reason: wrong polarity of the battery. But there was no doubt. When it went wrong, smoke came up.



  • I pretty sure the charging IC is dead. It now shows unhealthy looking bubbles on its surface after 2 minutes of operation without battery ... :-(
    The sensors of the board still work, as does the LoPy4 in the socket. But the board gets very hot without any battery connected. I'm sorry to say, but this looks like either a design issue, or faulty board - the IC itself has thermal, voltage and short cut protection built in, I fail to see what else could cause this. The battery was connected only for less than a minute yesterday and since then the bq24040 gets hot even if nothing is connected but USB.

    I would appreciate any advice on what could have gone wrong, I don't want to destroy my second board as well ...



  • Ok, so the spec sheet of the bq24040 charging regulator says it will limit the temperature of the chip to 125°C.
    So .. this might be normal operation ....?

    Also, the charging indicator is more intelligent than I thought, it actually follows a state machine to condition discharged batteries. However, there is a battery detection algorithm in place and I didn't find out why it does not detect the removal so far.

    Operation depends on how the chip is applied on the board, a schematic or hints on how this is implemented would be really helpful :-)



  • Thanks for the response!

    Gaoneng 600mAh 3.7V LiPo

    I read in the forums that if the battery is very low, it will not charge, so that would explain why the indicator LED does not light up if I connect it. If the current is really limited to 450mA, I would expet the board to get warm, but not hot. If you cannot touch it, it roughly means > 50°C

    What worries me is more that the charging indicator DOES light up when nothing is connected - where is that current going? I couldnt find a schematic of the board ...

    I ordered a standalone charger and will try again with fully loaded batteries.



  • @thingomat
    Can you give mode information on which battery you're using?
    Thanks


Log in to reply
 

Pycom on Twitter

Looks like your connection to Pycom Forum was lost, please wait while we try to reconnect.