VSCode Pymakr Plugin can upload at most 61 files

  • Our application contains 98 files at the moment.
    Whenever I try to upload all files to a LoPy4 it stops at 61 files and reboots. Further uploads don't do anything, because the project.pymakr file on the device contains all the files as if the upload were successful.
    The only reason to resolve this is to edit project.pymakr manually and remove all the files that did not get copied.

    It has been like this for quite some time (at least firmware version 1.15) and I think it is the same with Atom, but I am not sure.

  • I found the line and changed it.
    On Windows the path is: %USERPROFILE%\.vscode\extensions\pycom.pymakr-1.0.1\lib\board\sync.js

    It works now, thank you very much.
    This has bugged me for quite some time now.

  • Hi @Sympatron, Thanks for reporting. I've found a bug that causes this. It was an old piece of code for infinite-loop prevention, which was only needed for testing at the time, but was forgotten. Not many people have 60+ file projects :)

    I've solved it and will add it to the new release. If you can't wait, you can hack it with a small code change in your active package. Just delete the hardcoded depth condition (' || depth > 60') from this spot:
    or for atom:

  • @fstaine I would guess it is a bug in the firmware.
    I thinks it's odd that it is always 61. It is such an arbitrary number...

  • @sympatron


    It is indeed the same in Atom, as you can see in my post :

    Unfortunately, I have no better solution...

Log in to reply

Pycom on Twitter