Important update regarding LTE modem updates


  • administrators

    Hello everyone,

    Due to the increasing number of reports from users that the Sequans modem and FiPy/GPy are becoming unresponsive if the firmware upgrade fails, I have been investigating this issue intensively during the last few days.

    I have now discovered two issues that cause the modem to become "bricked".

    We have now received two corrections from Sequans that allow us to update the boot loader of the modem to ensure that the modem will always remain in a recoverable state. While the initial tests looks promising, I require a few more days to make sure that the new scripts and updated files will no longer brick the modem. Due to this we have decided to take the current firmware files and updater scripts offline and we highly suggest you do not try to update your modem until we can deliver scripts to do so safely.

    For those of you who have already bricked your modems, please let me apologise first of all that it took so long to discover the issue. We have updated more than a hundred modules ourselves without ever having any issues, so it took some serious effort to actually brick the modems in order to analyse and solve the issues.
    We will keep updating you on this over the coming days. I understand and share your frustration in the matter but we're working as hard as possible to get these issues sorted.

    Thanks a lot for your patience.



  • It appears that there has been some good progress with addressing a number of the issues with lte implimentation. Band 20 users are reporting connection success.

    What is happening with band 8 support my debelopment functions, along with others are dead in the water until the modem can support this band.

    Please provide an update on progress.



  • @robert-hh and @Xykon Thanks! I can see it has some bugs, but it has fixed the lte.isattached(). I get occasional OSError when I try a lte.connect() after lte.isattached() returns true



  • @einarj @Xykon has made a trial firmware package addressign this bug. You can find it at http://beta.pycom.io/nbiot-xykon/
    Download the matching package and install it using the path "Install from file".



  • Hi,

    There is something wrong with the lte.isattached() in the 1.18.1.r1 (also in the latest beta-release).
    When connecting a GPy to the Telenor NB-IoT network, we can verify the unit is attached, but the lte.isattached() gives 'False'
    Running AT+CEREG and AT+CGATT also shows the device should be attached to the network:

    lte.send_at_cmd('AT+CEREG?')
    '\r\n+CEREG: 2,1,"9DD1","0105C06B",9\r\n\r\nOK\r\n'

    lte.send_at_cmd('AT+CGATT?')
    '\r\n+CGATT: 1\r\n\r\nOK\r\n'

    lte.isattached()
    False

    Any suggestions?



  • @serafimsaudade There is a problem with the lte.attach() command in parsing the response to the AT+CEREG? command, issued by lte.attach(). What do you get after the attach command with the coommands:

    from network import LTE
    lte.send_at_command('AT+CEREG?')
    

    Attaching may take some time, like up to 15 Minutes.



  • @serafimsaudade said in Important update regarding LTE modem updates:

    Hi,

    I'm from Portugal, and I doing some testing the MEO NB network with 2 modems.
    1 - Mangohred WP7702
    2 - Pycom Gpy

    I can connect with wp7702, and send data to our cloud server over UDP, MQTT. I also check the band use by the modem to connect, and is using the band 20.

    With pycom, I try this code:

    lte = network.LTE()
    lte.send_at_cmd('AT+CGDCONT=1,"IP","internetm2m"')
    lte.attach(band=20)
    lte.isattached()
    

    And the response is always False.
    I update the sequans modem Firmware, but the result is the same.

    I came to the conclusion that the sequans fw is not ready for the portuguese network. Or I'm doing something wrong?

    cumps,
    Luís Santos

    The modem doesn't attach instantly, you should have the lte.isattached() in a loop like in the docs. Attaching can take minutes to complete.

    while not lte.isattached():
        pass
    print('Attached')
    


  • @dan please provide an indication as to when band 8 WILL be supported. It is nice to know that you are working on the problem but an expected release date would be greatly appreciated. Could you also please explain why direct emails to support@pycom.io and support team members go unanswered. This makes communication with the support team extremely difficult.



  • @kevin So this is what AT!="showCaps" returns:

    == CAPS config =============================
      .Lock UE on SRV band    : false
      .MFBI support           : true
      .TM8 TDD support        : false
    ============================================
    == CAPS ====================================
      . access stratum: R13
      . catM          : 1
      . nb-IoT        : 1
    -- EUTRA bands --
      . supported     : 28/20/13/12/4/3
      . board         : 3/4/12/13/20/28
      . admin         : 
      . pending admin : 
    -- EUTRA carriers --
      . admin         : 
      . pending admin : 
    ============================================
    

    Definitely no support for band 8. Something like that would have been clear if shown right in the beginning.



  • @dan thanx a lot for feedback, can't wait to see band=8 and isattached=true !



  • We are working on the additional bands with Sequans. We will post an update when we have more information. Thanks for your patience



  • @robert-hh

    @xykon said in Important update regarding LTE modem updates:

    In regards to band 8, I was informed now that, while the hardware supports all bands (1,2,3,4,5,8,12,13,18,19,20,28), the Sequans firmware currently only supports a maximum of 6 bands so we chose the ones that gave us the best support at the time of launch. I have a call with Sequans later today to discuss this limitation and provide a firmware that can be used with band 8 as soon as possible. I hope to have an update on that within 24 hours.

    The six bands that Pycom chose - i.e., the only ones currently supported by Sequans FW - are 3/4/12/13/20/28. We raised this issue about 8 months ago (https://forum.pycom.io/topic/2496/gpy-readiness/17), but still no progress.



  • @tuftec I've read them all, and the conclusion is not obvious. Therefore I ask, if you have another source.



  • @robert-hh suggest you read the other posts in this thread. Particularly those from @Xykon.

    It appears that the Sequans modem is not currently configured for band 8 support. A new firmware update is required.

    Peter.



  • @tuftec What is your source of the missing band 8 support? Doers it tell that the Sequans firmware, or the Pycom firmware, not passing the request to the Sequans firmware.
    If I compare the behavior between band 20 and band 8, it looks pretty similar. All commands are accepted, and then the Sequans modem is reporting alternating CEREG 2 and CEREG 0 on its TX line, only the period is different. For band 20, the period is 45 seconds, for band 8 it is 225 seconds.



  • @robert-hh still wait on a response to band 8 support.
    It appears that it is currently not supported.
    This has put a halt to our developments at present.
    Peter.



  • @xykon Today I got the information that T-Mobile Germany uses band 8 for NBIoT (900 MHz band). So it would be useful to know, if this band is supported by the Sequans firmware is the attach is requested by the command AT!="RRC::addscanband band=8"
    Trying to do that did not succeed even after 2 hours waiting.
    At least, AT+CSQ tells me, that a cell is seen and a good signal can be received. But I have to go through a hard reset to get that.



  • Hi,

    I'm from Portugal, and I doing some testing the MEO NB network with 2 modems.
    1 - Mangohred WP7702
    2 - Pycom Gpy

    I can connect with wp7702, and send data to our cloud server over UDP, MQTT. I also check the band use by the modem to connect, and is using the band 20.

    With pycom, I try this code:

    lte = network.LTE()
    lte.send_at_cmd('AT+CGDCONT=1,"IP","internetm2m"')
    lte.attach(band=20)
    lte.isattached()
    

    And the response is always False.
    I update the sequans modem Firmware, but the result is the same.

    I came to the conclusion that the sequans fw is not ready for the portuguese network. Or I'm doing something wrong?

    cumps,
    Luís Santos



  • There is one more issue. Test application was sending MQTT message once per minute. After approx. 5 hours MQTT client returned exception [Errno 113] EHOSTUNREACH and each following attempt to reconnect to MQTT broker was unsuccessful.
    The application also checks lte.isattached() and lte.isconnected() in each loop and if there is a change of state it prints out notification. There were no notifications therefore I assume that state of both lte.isattached() and lte.isconnected() remained True.



  • I performed successful tests in NB-IoT network of Slovak Telekom with Sequans FW NB1-38729 and Pycom FW 1.18.1.r2 provided by @Xykon .

    As suggested by @peterv it was possible to reduce the code to:

    lte = network.LTE()
    lte.send_at_cmd('AT+CGDCONT=1,"IP","nbiot.telekom.sk"')
    lte.attach(band=20)
    

    Issues which remain unsolved from my point of view are:

    • working DNS over NB-IoT connection
    • support of PSM and eDRX

 

Pycom on Twitter