Lopy4 will not boot via battery power on Expansion Board



  • I'm seeing a strange thing, the Lopy4 on Expansion 3 will not boot and run my program most of the time from battery. It runs just fine when powered by USB (code is in main.py). Basically if I power via USB there is no issue, but powering via battery rarely works. Maybe it will boot about 1% of the time when I hit the reset button from battery. I can start with USB then plug in a battery and then unplug USB and it runs fine until you hit reset again.

    Any ideas what to do? I just made sure the expansion board 3.0 and Lopy4 were on the latest firmware (stable). This puts a big damper in a demo I have in a couple of weeks where the Lopy has to be in a case on battery. Anything I should try? All jumpers are installed, and the batteries are just fine.

    I can move the Lopy4 to a Pysense and it runs just fine without making any changes. Very weird that it has trouble only when connected to the expansion board.

    Expansion board 3 is running 0.0.9 (fails to boot most of the time)
    Pysense is running 0.0.8 (boots every time)
    Lopy4 is running 1.18.1.r1 (stable)



  • Is something similar an issue for the PySense?

    It does not seem to get out of sleep when on battery while on USB power it works fine.
    Battery is for sure fully charged (4.2 v during charching, when connected 4.1V without charging)

    What is the reason for "pull P8 (G15) high"?
    Please note full advise is: "pull P8 (G15) high, and if you need the SD card, use a 10k pull-up"



  • Thanks, I ran the jumper from 3.3v to P8 and that solved the issue.




Log in to reply
 

Pycom on Twitter