Expansion Board 3.0 bad?



  • I'm just starting to build the first batch of some prototypes based on GPy and Expansion Board 3.0. I assembled the first one, with both components new out of the box and having issues with it. I'm wondering if maybe I have a bad expansion board?

    Observations:

    • The GPy boots normally and I can connect via REPL, updater, run my code, etc.
    • I measured around 2.3V at various places where I had pulled voltage off of the 3V3 pin. My other test board shows 3.3V at the same points.
    • SD card won't initialize
    • I2C bus won't initialize

    Has anyone else seen this type of problem? I'm wondering if I just have a bad expansion board or if I'm doing something wrong.



  • @crumble Is your code easily shareable? I'd like to leave it running on a module overnight here and see if I can reproduce this. because its super weird. feel free to share it via email with paul@pycom.io if you'd prefer it to remain private :)



  • @paul-thornton said in Expansion Board 3.0 bad?:

    Out of curiosity.

    If it will be that easy hugh

    I struggle a lot with my pytrack LoPy combination. Yes, these 5 seconds will fix a lot of problems, but not all. sometimes I get really strange problems :

    • _actLen = self.i2c.readfrom_into(GPS_I2CADDR, self._buffer) failed with out of bounce
    • data will be missed from L76 so, that I get the start of a one and the end of another sentence.
    • deep sleep will not work. Machine prints all data to the console and does nothing. Power usage is high and ctrl-c will do nothing.

    The best of all. It seems that only one type of such an error occurs on a day. Never all of them together. They show up only at night or in the morning. As soon as I start to localize them and surounded them with prints, they run like a charme until the next night.

    I assumed a voltage problem and use now an active hub. Still fails inthe same way. I placed it in the fridge for 30 min and it failed in the afternoon. But in the morning it fails with room temperature as well. I tried to plug it out vor 1.5 min, but it worked.

    I really have no clue, but it is unreliable, but in some kind predictable. It sounds like a strange mixture of temperature and time side effect in the i2c module. Sounds too odd in my ears.

    Is the pic connected with I2C on your boards?



  • @reidfo That could by a supply problem. What voltage do you see at the Vin pin of the GPY, when the voltage at the 3.3V pin is lower than 3.3V. And did you try another USB cable?



  • Out of curiosity. Does the issue persist if you add say a 5 second or so sleep to the first line of your statup code?
    The board does take some time to initialize i2c / SD cards and run a few other background tasks.



  • @luca-gamma Thanks for pointing out the lack of clarity in my post. No, I meant just the expansion board and the GPy.



  • @reidfo Nothing you mean also without development board? I suppose the 3.3V comes from the regulator installed on any *py board so without devel board the 3.3V pin takes an undefinate state...



  • @paul-thornton It's fairly inconsistent. I'm measuring between the gnd and 3v3 pins with nothing but USB attached to the expansion board. I got 3.3v once, and on subsequent power cycles I got between 1.5 and 3.1 volts. Typically it's around 2.5-2.7.



  • Just posted a new topic about this issue. Same problem here with exp. board 3 and gpy reading SD card with 10k pull-up on SD_DAT. Voltage on 3V3 pin is actually 3.29V when powering via USB.



  • Hi

    Could you confirm that the 3v3 pin is showing a lower voltage without additional components attached, (Ie just the GPy and expansion board attached).

    Also how are you powering the Expansion board/GPy, usb or battery?


Log in to reply
 

Pycom on Twitter