boot.py reliability



  • @kjm Are you sure it completely fails to load/run m2m.py? Or could it start and just crash a bit further during execution?

    Are you also sure it never fails with the script directly in boot.py?



  • @kjm does it work when you put m2m.py at the same place as main.py?



  • @kjm said in boot.py reliability:

    @jcaron This was crashing before I added the led to see where it was happening.

    There are multiple ways how your program may fail during startup. If you have only a small RAM device you may run into out of memories during compile or init time. Memory fragmentation may vary for eexample with loops waiting for network or other resources.

    Importing faulty modules may halt the system without useful error messages. Test your imports. I ran into this by typing into the wrong window and noticed it only when it ran into the right path on startup.

    The pytrack needs some time time for a clean i2c access. My device needs up to 5 seconds. Be sure that you are testing the device with nearly the same timings. So don't use print statements only when *Py is connected to your development machine.

    At best you cahnge the LED color at the first line of your m2m.py
    Additionaly after a few imports, so you can do a binary search for a failing import.

    Add a try-except statements aournd your main parts and write the exception into flash.



  • @jcaron This was crashing before I added the led to see where it was happening. I'm logging the LiPo cell voltage, it shows the same upward trend regardless of the days temperature. If this happened when I tried to use the lte I'd suspect the battery but simply loading a program from a different folder shouldn't change the current demand. The gpy is specd to work from 3.5-5.5v supply on Vin so as long as the battery stays above 3v5 I figure it should work.



  • @kjm Maybe the LED is adding a few extra degrees, or adding a bit to the power consumption, and your battery doesn't like the combination of heat and extra power requirements?

    Batteries can behave quite differently when deviating significantly from "usual" room temperatures.



  • Already tried that plus a few other path combos Rob, always stops working eventually. I've got a suspicion it's temperature related. Always happens in the heat of the day, gets up to 55 celsius in the little solar enclosure that keeps the battery charged. But 50 celsius should be OK shouldn't it? And it doesn't fall at that temperature if I make my program boot.py



  • @kjm Since the RGB LED get's white, boot.py is executed. What does not seem to get executed is m2m.py, which is called instead of main.py. Could you try to specify the full path name '/flash/client/m2m.py' ?


 

Pycom on Twitter