Fipy & PyTrack 1.1 - no connection to Microcontroller



  • Hi there,

    I got some devices from you yesterday and enthusiasticely i started playing around.
    Updated all Firmwares: Gpy, FiPy, pysense, pytrack, modems, followed guides and tried testscripts

    Unfortunately the pytrack board does not connect to any of the microcontrollers.
    The Com Port shows up but then nothing ever happens.

    I have no issues with the pysense board and the same microcontrollers.

    Is there anything i can do to check if it is a faulty board?

    Thanks
    Chris



  • I don't have a PyTrack, but I've had similar problems with a couple of expansion boards. Flashing the expansion board firmware with dfu-util worked for me.



    • When Trying a Firmware update with Pycom Upgrade it says -> Failed to connect to ESP32: Timed out waiting packet header

    • When connecting it via pymakr it says Connection error: Error: timeout

    The Fipy obviously has power because the led is blinking blue



  • Which error do you get?

    i2c bus error? In this case wait 10sec before you init the pytrack. It needs upto 5sec to be ready. If you wait longer, you shall get around this problem.


Log in to reply
 

Pycom on Twitter