GPy ValueError: band 8 not supported by this board hardware!

  • When i try to attach my GPy to NB-IoT band 8 in germany (1nce) with

    from network import LTE
    lte = LTE()
    lte.attach(band=8, apn="")

    it get the following error message on my GPy:

    ValueError: band 8 not supported by this board hardware!

    I upgraded my NB-IoT Modem successfully to the newest Version 41019 and the GPy has the newest stable firmware (1.18.2.r4) as well


    Welcome to the SQN3330 firmware updater [1.2.5] 
    GPy with firmware version 1.18.2.r4
    Your modem is in application mode. Here is the current version:
    IMEI: ...


    print(lte.send_at_cmd('AT!="RRC:setDbgPerm full"'))


    == CAPS config =============================
      .Lock UE on SRV band    : false
      .MFBI support           : true
      .TM8 TDD support        : false
    == CAPS ====================================
      . access stratum: R13
      . catM          : 1
      . nb-IoT        : 1
    -- EUTRA bands --
      . supported     : 66/28/26/25/20/19/18/17/14/13/12/8/5/4/3/2/1
      . board         : 1/2/3/4/5/8/12/13/14/17/18/19/20/25/26/28/66
      . admin         :
      . pending admin :
    -- EUTRA carriers --
      . admin         :
      . pending admin :

    Did I miss something? According to the patch news
    "Added Check for LTE band support against both SW and HW versions of the LTE modem." (
    my GPy hard- and software should support band 8 if I am not mistaken.

    Does band 8 work for anyone? Has anybody struggled with the same error message?

  • @robert-hh ok thank you for your time !

  • @Tgasser If attach is sometimes successful, then the board is fine. The error I flagged is fixed in version 1.20.1, but that seems not to be available for download.

  • @robert-hh I have the FiPy model 1.0 but version 1.2 which is normally good no?
    I read your topic ( FiPy, LTE: Regression error - no band 8 support ), I made the downgrade of the firmware to v1.20.0.rc11 and I got to connect on the band 8 but sometimes I still have the error that appears.

  • @harix What happens if you omit band=8 in the call of lte.attach(). If it is just the error I flagged, it should then work. The code will then listen on all supported bands.

  • @Tgasser If it is a FiPy 1.0, you have to send it back for replacement.

  • Hello @robert-hh , I just want to confirm that if I have the same problem and the same information that appears on the console, I have to send it back to unlock it? Knowing that I have the FiPy 1.0 V1.2?

    Thank you :)

  • I can also confirm that the latest firmware (NB1-41019) that it does not work with "band=8"

  • @robert-hh ok, thanks a lot for your time.
    I guess i have to wait until the other two boards return and test them instead.

  • @bqpd I had two FiPy boards which were exchanged by Pycom. The new firmware may report band 8 support when the hardware might not support it. The code checks for a specific modem version, and that might be wrong.

  • @robert-hh Ok, thanks for your responses.

    I changed to V1.20.0.r9 now, but i still get the same Error.

    Do you have any other suggestions why it would throw the band 8 not supported by this board hardware! when at!="RRC:showcaps" lists band 8 as supported?

    My GPy is one of the newer GPys where band 8 support should have been included by delivery (i have not sent it back to unlock it).
    One older GPy and a FiPy are on their way back to pycom at the moment.

    Is your GPy one you sent back to get band 8 unlocked?

  • @bqpd I use at the moment V1.20.0.r9 and Sequans firmware 41019. Since then, no tricks. I also looked up the NbIot coverage in the Jena region. It has some white spots like every place, but in general it's good.

  • @robert-hh And have you upgraded your firmware to 1.18.2.r4 on the GPy and version 41019 for the Sequans modem yet?

    I remember you said that it worked for you on an other thread (
    I also tested your code with the older firmware and tried for 45 minutes to get a connection, but that failed in the end.
    But at least i could run the lte.attach(band=8, apn="") command back then.

    Now with the newest firmware I get the error stated above when trying to attach (ValueError: band 8 not supported by this board hardware!)

  • @bqpd I can confirm that band 8 works for me. The first attach took like forever (> 10 Minutes, long when you wait for it), but now it attaches after a power cycle within 10-20 seconds. Still slow compared to my other LTE module, which attaches immediately, unless it had been offline for days.

Log in to reply

Pycom on Twitter