No gateway on LTE

  • Hi All,
    Until last Saturday at 6pm I could use the Telstra CAT M1 network with no problems. After 6pm everything stopped. I get an LTE connection and can attach, but nothing works. Checking the details of the attachment with print(lte.send_at_cmd("AT+CGCONTRDP")) returns:


    From what I can see everything looks ok - except there is no default gateway specified. That doesn't seem correct to me, but having not bothered to look while it was working (hey, why would you? ;-) I can't be sure. Is there anyone using Telstra or Hologram who can see if they get a gateway, or who know what this should look like?

    (I would have posted this against the cellular group, but it doesn't seem open to posts)

  • @misterlisty is that out for CAT M1, or just NB-IoT?

  • @John-Baird Try the latest version which i think it up to 4xxxx I had heaps of problems till i upgraded modem firmware

  • Ok, sorry all. Turns out the pinout diagram for the PyScan I was referencing had an issue and I'd mixed the LTE and GPS Rx lines. Interesting that the modem still mostly worked due to the relatively low speed of the GPS.

  • @misterlisty The modem is loaded with 39529 and I've tried several version of firmware on both a FiPy and a GPy. It attaches and connects - but can't open a connection. It appears the DNS query won't work, nor can I open a socket by IP. When I get home I'll post the relevent code, but it's fairly straight forward.


  • Have you update the LTE firmware? What version you using? I solved many issues when updating it.

Log in to reply

Pycom on Twitter