Power consumption deep sleep Pysense + lopy4



  • Hey guys

    I'm running a lopy4 + pysense shield the firmware of the lopy4 is:
    (sysname='LoPy4', nodename='LoPy4', release='1.18.2.r5', version='v1.8.6-849-86b2375 on 2019-03-15', machine='LoPy4 with ESP32', lorawan='1.0.2', sigfox='1.0.1')

    and the pysense is 0.0.8

    I'm reading with a

    3.7V LiPo battery
    Normal sleep: ~40mA
    Deep sleep: ~2.5mA

    According to the specs, this should not be normal.
    Anyone else experiencing similar issues?

    I've allready uploaded the latest firmware, (allready tried with developer and pybites firmware also)
    Already turned of bluetooth and wifi on boot.py.

    Also with only the lopy4 and the machine deepsleep with battery in Vin pin i get around 10uA which is nice.
    but with py.go_to_sleep() and with battery pluged in normally i can't pass the 2.15 mA i need it to be in the uA range, because i'm doing a project that needs battery autonomy.

    #boot.py
    from network import WLAN
    from network import WLAN
    from network import Bluetooth
    import pycom
    from machine import UART
    import os
    
    # uart = UART(0, 115200)
    # os.dupterm(uart)
    pycom.wifi_on_boot(False)
    wlan = WLAN()
    wlan.deinit()
    bluetooth = Bluetooth()
    bluetooth.deinit()
    
    from network import LoRa
    from network import WLAN
    import machine
    import socket
    import ubinascii
    import struct
    import time
    import config
    import pycom
    from pysense import Pysense
    from deepsleep import DeepSleep
    import deepsleep
    from LIS2HH12 import LIS2HH12
    from SI7006A20 import SI7006A20
    from LTR329ALS01 import LTR329ALS01
    from MPL3115A2 import MPL3115A2,ALTITUDE,PRESSURE
    from math import log
    from struct import *
    import base64
    import gc
    
    while(True):
        print("going to sleep")
        time.sleep(2)
        py.setup_sleep(30)   # setup a 10 seconds sleep time
        py.go_to_sleep()
        time.sleep(2)
        pycom.rgbled(0xff0000)
        time.sleep(2)
    


  • @morrison Glad you found. From the documentation it can only be guessed. The sections about pytrack and pysense are a little bit mixed.



  • i got a possible answer to this subject....

    instead of

    py.go_to_sleep()
    

    i put:

    py.go.to.sleep(False)
    

    that did the trick for me .... For future things with this problem
    and i see many people like myself facing this obstacle and not getting to the
    10 uA range advertised by the pysense. So try:

    • update firmware
    • update libs
    • turn off bluetooth and wifi
    • use py.go_to_sleep(False)

    that's everything i tried until now and eventually worked!

    Thanks guys



  • @robert-hh I took the sd card as soon as i've seen your question...
    but still is in the 2.something mA and oscilatting...

    I'm really out of ideas, i've uploaded the latest firmware, libs etc



  • @morrison Did you read the current without the SD card? I have an application with SD card too (not a Pycom device), where most of the ~2.5 mA standby current is consumed by the SD card. In my case that is not critical.



  • yes i do



  • @morrison Do you have a SD card inserted in the Pysense shield?


Log in to reply
 

Pycom on Twitter