Lopy4 not communicating with atom

  • Hi,

    I just bought a fipy, a lopy and two V3.1 expansion board from mouser. Initially I was able to run all the example applications like the lorawan-nano gateway and others and i was even successfully sending data to things network. one fine day, I was writing some sample code and after flashing it my lopy board stopped communication with atom, and soon enough i was not able to connect to the fipy board as well(this after firmware upgrade). I am getting the following error

    Connecting to COM8...

    Failed to connect (Error: Port is not open). Click here to try again.
    Failed to connect (Error: Port is not open). Click here to try again.
    Connecting to COM8...
    Connection error: Error: timeout

    I am now unable to flash any code.

    I tried updating the latest firmware of both lopy and fipy. I even tried the downgrading but still it shows the above message. I tried to use arduino IDE as well and a separate usb to ttl converter with lopy but no use.

    There are no other COM ports or terminal running while i try flashing the code. upon getting the serial ports, I get this from REPL terminal

    Found 2 serialports
    COM8 (Microsoft) (copied to clipboard)
    COM1 ((Standard port types))

    All the jumpers are connected.

    Now using the firmware upgrade tool. I am able to flash different firmware but not able to connect to atom or flash code through arduino IDE. only a blue light keeps blinking.

    Can anyone please help me?

  • Did you solve this?? I am having the same problem. I tried the same things and had no success. Thanks.

Log in to reply

Pycom on Twitter