pymakr does not start

  • Hi @wathoom,

    From your previous error log, I can see is using PyQt 5.7 thought. Is this still the case? Can you confirm me if you have both version 4 and 5 installed simultaneously?

  • Pybytes Beta

    Hi abilio,

    pyqt4 is already installed.

  • Hi @robert-hh,

    I can sense your frustration on trying Pymakr and not being able to run it. I went into downloading the Debian Jessie from the official website and installed it in a VirtualBox machine, with Cinnamon as the UI. I then downloaded the deb installer from our website, and proceeded to install it with these steps:

    sudo dpkg -i pymakr_1.0.0.b6-1_all.deb
    sudo apt-get install -f

    Then I started the app from the menu, and it worked.

    I really want to help you to find a solution for your specific setup, but I'll need further feedback from you in order to do so.


  • Are you sure that pymakr is using PyQT4? If yes, Why do I get the error message:

    from PyQt5.Qsci import QSCINTILLA_VERSION_STR, QsciScintilla

    b.t.w: I can import PyQt4,Qsci.

    Today's build is still not running. As long as such a crap is out, you shpould not issue board which cannot be used without pymakr.

  • @wathoom, even when most of the codebase is compatible with PyQt5, we're using PyQt4. Internally, Pymakr would import it if available, no matter if the code read PyQt5. Can you try installing PyQt 4 on your computer?

  • Hi,

    I gave in trying. As a test, I installed the Windows version, just to see, that for me PyMakr is as useless as before. Practically, It's just another Editor. The integration of the modules does not seem to exist. PyCom should focus their energy in making the firmware for their devices.

    Best Regards

  • Pybytes Beta


    I had same problem as above. After installing python-pyqt5.qsci package it got bit further.
    Now i get following error:

    Python 2.7.12+
    An unhandled exception occurred. Please report the problem
    using the error reporting dialog or via email to
    A log has been written to "~/.pymakr/pymakr_error.log".

    Error information:

    2016-10-31, 16:45:11

    <type 'exceptions.ImportError'>:
    cannot import name QLabel

    File "/usr/share/pymakr/modules/", line 368, in <module>
    File "/usr/share/pymakr/modules/", line 288, in main
    from UI.SplashScreen import SplashScreen, NoneSplashScreen
    File "/usr/share/pymakr/modules/UI/", line 16, in <module>
    from PyQt5.QtGui import QPixmap, QColor, QLabel

    Version Numbers:
    Python 2.7.12+
    Qt 5.6.1
    PyQt 5.7
    sip 4.18.1
    QScintilla 2.9.3
    WebKit 538.1
    Pymakr 1.0.0.b5

    Platform: linux2
    2.7.12+ (default, Sep 1 2016, 20:27:38)
    [GCC 6.2.0 20160927]

    Distribution Info:
    PRETTY_NAME="Debian GNU/Linux stretch/sid"
    NAME="Debian GNU/Linux"

  • @robert-hh Thanks for your feedback. We'll have to further study the case directly in Debian Jessie and see what's going on. In the meantime, if you wanna try, the error means QScintilla (and other dependencies) are not being found. This mean either it wasn't installed, or it was installed for another Python interpreter in the system.

  • Tried it. No sucess. The same error is thrown.

  • @robert-hh A new version of Pymakr has just been released. We believe this bug has been partially fixed with it. There is some specific Linux information, so I invite you to check the release notes at:

  • Thanks for your report on the bug. We're aware of it, and the next version of Pymakr fixes this and other small bugs. Stay tuned for the upcoming release this week.

Log in to reply

Pycom on Twitter