Gpy with PySense won't Attach.



  • I seem to be having the same issue as the person who made this post, which sadly, remains unanswered.

    I'm running the current Script in order to merely test the connection:

    from network import LTE
    import time
    
    lte = LTE()
    
    lte.send_at_cmd('AT+CFUN=0')
    lte.send_at_cmd('AT!="clearscanconfig"')
    lte.send_at_cmd('AT!="addscanfreq band=20 dl-earfcn=20404"')
    lte.send_at_cmd('AT!="zsp0:npc 1"')
    lte.send_at_cmd('AT+CGDCONT=1,"IP","nb.inetd.gdsp"')
    lte.send_at_cmd('AT+CEMODE=0')
    lte.send_at_cmd('AT+CFUN=1')
    
    lte.attach(band=20, apn="nb.inetd.gdsp")
    print('Attempting to Attach.')
    while not lte.isattached():
        time.sleep(1)
        print(".", end='')
    print(' OK')
    lte.connect()       # start a data session and obtain an IP address
    print('Attempting to Connect.')
    while not lte.isconnected():
        time.sleep(1)
        print(".", end='')
    print(' OK')
    

    The Script then loops in while not lte.isattached(): and never seems to succeed to connect.

    I tried it with multiple SIM-cards that we have here from various providers, changing settings accordingly, but no luck.

    Also did make sure to have the right firmware flashed to the Sequens Modem.



  • @NickBoots What is your modem's firmware version?



  • @jcaron

    Huh, managed to flash 1.18 to it, somehow, the link provided in Documentation still gives Pycom Firmware Updater 1.15.1, I don't know if this is the latest, but et only wants to flash the firmware with the same version number as itself? Managed to manually download 1.18.2r7, will test if it Attaches now.

    Update: Still no luck with this, by the way, this is the same Firmware I just noticed as the person used in the topic that I linked in my opening post.



  • @NickBoots The latest stable release is 1.18.2r7.

    Make sure you have the latest firmware updater.



  • @jcaron It's... The latest Stable release...

    So, Dev release then? Also no newer version for the PySense.



  • @NickBoots I recommend you start by updating the GPy firmware (1.15 is over a year old), and the LTE modem firmware as well. There have many changes in the LTE support since then.



  • @jcaron

    The hardware used is the Gpy v1.0 on a PySense v1.1.

    Gpy firmware is 1.15.1, PySense firmware is 0.0.8.

    I'm trying to connect to the is Vodafone's Narrowband-IoT in the Netherlands.



  • @NickBoots Can you clarify the versions of:

    • the GPy (hardware)
    • the GPy firmware
    • the modem firmware

    As well as the networks you are trying to connect to?


Log in to reply
 

Pycom on Twitter