sequans modem becomes unusable



  • I've reported this issue in June

    https://github.com/pycom/pycom-micropython-sigfox/issues/308

    and have hit it again. It seems the sequans modem has somehow become corrupt and reflashing doesn't help

    I was installing a G01 based system in a trial customer site yesterday. The system was running fine on battery and talking to vodafone NBIoT network in Ireland. During the install the battery died (no big deal the battery is just intended for short power outages). When I powered on the system from mains it would not connect to the NBIOT network. It responds sanely to many AT commands, I can read the ICCID of the sim card, CEREG, CFUN etc seem to repond okay, but I started getting responses to e.g. the COPS command (which works on 10+ other systems and worked on this one earlier) similar to those in the bug I logged:

    ^EXIT: File: rfcChar.c@107

    and I got a few other weird AT command responses e.g.:

    ^EXIT: File: exl.c@619

    reseting, powering off/on didn't help. I tried to reflash the modem with the previous FW (didn't help) and again with the latest (didn't help)

    sqnsupgrade.info()
    <<< Welcome to the SQN3330 firmware updater [1.2.5] >>>

    GPy with firmware version 1.18.2.r7
    Your modem is in application mode. Here is the current version:
    UE6.0.0.0
    LR6.0.0.0-41019

    Has anyone seen this? Is anyone from pycom or sequans looking into issues relating to the gpy/g01/fipy modem?



  • I dont know if it will help but i work with some different embedded board and it's look like the following.
    The main power as not enougth output to provide peak current when modem try to attache the network, with gsm/gprs it's a burst peak current over 1A, with NbIoT it's above 600mA.
    Change your battery, wait for it to be fully charged and after that try again.
    Once attached the peak current is lower with NbIoT and the trouble is gone.



  • it looks like the COPS command causes a modem crash and a restart

    lte.send_at_cmd('AT+CEREG?').replace('\r\n','')
    '+CEREG: 2,0OK'
    lte.send_at_cmd('AT+COPS?').replace('\r\n','')
    '+COPS: 1OK'
    lte.send_at_cmd('AT+COPS=1,2,"27201"').replace('\r\n','')
    '^EXIT: File: rfcChar.c@107'
    lte.send_at_cmd('AT+COPS=1,2,"27201"').replace('\r\n','')
    '+SYSSTART'
    lte.send_at_cmd('AT+COPS=1,2,"27201"').replace('\r\n','')
    'ERROR'


Log in to reply
 

Pycom on Twitter