machine.pin_sleep_wakeup renamed?



  • We use a couple of GPys and we have an issue with machine.pin_sleep_wakeup that now seems to have been renamed. It worked in the past but current software versions, no, not so much. We now get the error ”name is not defined” when running a line of code that always has worked before. Issue is seen in 1.18.3 and also 1.20.3.b0. The function is described in Pycom documentation here -would be wonderful to understand what the correct name of the function is nowadays.



  • @Gijs Honestly I think the Pycom documentation is seriously lacking in versioning. At the very least, new features / methods / options should be clearly marked as "introduced in version XXX". This would save a lot of time and energy for people trying things that are in the docs but are not in the version of the firmware they are currently running.

    Likewise, breaking changes should be documented.



  • @Gijs From my experience of working with PyCom, you have changed the names of two commands in ~9 months, the makefs() command and now this. Isn't that considered as more than "very often"?


  • Global Moderator

    Im sorry to tell you they are not documented, as these changes are not occuring very often. The documentation is currenlty only available for the latest firmware version and the development release as to not confuse people with old functions that no longer work..



  • Thanks @jcaron we have not taken notice of that, we will change immediately. Do you by any chance know where these kind of changes between software versions are documented so one can keep track of it?



  • @Don-iot the function was renamed a while back from pin_deepsleep_wakeup to pin_sleep_wakeup, notice the “deep” that was removed.

    Which version are you actually trying to call?


Log in to reply
 

Pycom on Twitter