PyTrack 2.0 - esp_image: Checksum failed. Calculated 0x36 read 0x16

  • My PyTrack 2.0, in combination with the gpy, is having issues with booting up after I updated the firmware version to version 16 (pytrack2_v16.dfu).
    It keeps throwing the following error that the checksum is failing for the device. Also, I tried to find an older firmware version or perform an update via the PyCom update firmware tool but this tool also keeps failing.

    I tried to do the whole upgrade process on multiple PC's (Linux and Windows), but no success so far.

    configsip: 0, SPIWP:0xee
    mode:DIO, clock div:1
    entry 0x400a05bc
    E (552) esp_image: Checksum failed. Calculated 0x36 read 0x16

    Logs of the firmware upgrade progress:

    dfu-util.exe -D pytrack2_v16.dfu
    dfu-util 0.9
    Copyright 2005-2009 Weston Schmidt, Harald Welte and OpenMoko Inc.
    Copyright 2010-2016 Tormod Volden and Stefan Schmidt
    This program is Free Software and has ABSOLUTELY NO WARRANTY
    Please report bugs to
    Match vendor ID from file: 04d8
    Match product ID from file: f014
    Opening DFU capable USB device...
    ID 04d8:f014
    Run-time device DFU version 0100
    Claiming USB DFU Runtime Interface...
    Determining device status: state = dfuIDLE, status = 0
    WARNING: Runtime device already in DFU state ?!?
    Claiming USB DFU Interface...
    Setting Alternate Setting #0 ...
    Determining device status: state = dfuIDLE, status = 0
    dfuIDLE, continuing
    DFU mode device DFU version 0100
    Device returned transfer size 64
    Copying data from PC to DFU device
    Download        [=========================] 100%        16384 bytes
    Download done.
    state(2) = dfuIDLE, status(0) = No error condition is present

Pycom on Twitter