Pymakr Atom Plugin released



  • Hi,

    I just updated to Pymakr 1.1.3 in Atom (macOS). Ever since the update I get the following error when trying to sync:

    Reading file status
    Synchronizing failed: timeout. Please reboot your device manually.

    I do have a connection and Running files doesn't seem to be a problem. But I can not get it to sync.

    I've tried both soft, hard and factory reset of the LoPy as instructed on:

    https://docs.pycom.io/chapter/toolsandfeatures/bootmodes.html

    If anyone can help I would be grateful.

    Mathies

    edit: I've also tried upgrading the firmware.



  • @ralph, okay thank you. Looking for the update.


  • Global Moderator

    Hi @lesure1, thanks for reporting this. I've just tested it on ubuntu and it seems that the serialport lib is not working properly for this version on ubuntu. I'm inspecting and fixing it now and will send you an updated plugin tomorrow to see if it's working.



  • Hello,

    I am trying to connect to Pycom (1.1.3) from Atom editor (Atom: 1.20.1, Electron: 1.6.9, Chrome: 56.0.2924.87, Node: 7.4.0) on Ubuntu 14.04. I added Pymkr 1.1.3 automatically using the Atom GUI. The Atom editor crashes when clicking on connect, after retrieving and setting the USB serial port for Pycom. The message displayed is "Editor has crashed. Please report this issue". I am totally new to the environment and trying to do my first set up. Could anyone help me identify the source of the problem and fix it?

    Thank you!


  • Global Moderator

    @MJ @danielm A new version has been released. Let me know if this solves your issues.


  • Global Moderator

    @mj @danielm I see your issue. To explain: from pymakr 1.1.0 on we added a version limit to the plugin (<=1.20.0), with the goal to make sure that when a new version of atom comes out, we can test it before we release the plugin for it as well. The problem is that if you are on an old pymakr version before this limiter, but update straight to a new release (1.20.1 was released last week) you'll be stuck with an incompatible version.

    I'll test pymakr with the latest Atom and will release 1.1.2 very soon. A quick fix would be to downgrade to atom 1.20.0, then update pymakr to 1.1.1



  • @danielm Hi, i am new here. I also facing the same problem as you. May i know how can we fix it?



  • On Windows 7 with Atom 1.20.1x64 only Pymakr version 1.0.3 is offered as latest compatible version.

    0_1506173579924_pymakr.png

    Then the package fails to be loaded anyway:

    0_1506173753011_pymakr2.png



  • On my Mac I installed last ver of Atom (1.20.0 x64) and pymakr plugin (1.0.3). I'm connected to LoPy through serial.
    After I created a simple file test.py containing this:

    import uos
    uos.uname()
    

    Sync &Running the project with Atom raise errors. Do I have to configure something to run a simple python file?

    >>>
    >>
    Traceback (most recent call last):
      File "<stdin>", line 2, in <module>
    NameError: name 'null' is not defined
    >
    MicroPython 8a4f37d-dirty on 2017-09-17; LoPy with ESP32
    Type "help()" for more information.

  • Global Moderator

    V1.1.0 update. Includes a big refactor round that gets the code in line with the VSCode plugin. This has very little effect on the UI and features, except for a new config option 'open_on_start' that can be used to hide the plugin by default. All problems with the serialport should also be resolved (bindings file not found and serialport version mismatch errors), as long as you are on the latest atom version (1.19 or higher)

    • Big refactor to get a shared base code with the VSCode plugin
    • Added 'open_on_start' config
    • Fixes issues with serialport lib for newer versions of atom
    • Bugfix in the run feature on linux.
    • More relaxed keep-alive protocol on telnet (ping has to fail twice before connection break)

  • Pybytes Beta

    @Ralph I' m getting this error when I try to install Pymakr plugin 1.0.3 (I' ve tried to update from 1.0.2 and it crashed, so I' ve unistalled to reinstall it).

    0_1500029112717_Error Pymakr.JPG



  • @Ralph Thank you. It works.


  • Global Moderator

    @Manuel That works, but if you want to use 1.0.3, you can completely uninstall and then re install the plugin to make it work. There is an issue with a few files that fail to update to the new code in the folder, for unknown reasons. Only happens on windows it seems. We're working on a permanent solution.



  • @ozeta I have the same problem in 2 windows 10 machines (64 bits).

    Using this https://forum.pycom.io/topic/1137/downgrade-atom-pymkr-plugin should fix the problem.

    Try with "apm install Pymakr@1.0.2" in cmd or PowerShell (if you are using windows). It worked for me.



  • @Ralph I have atom 1.18 and before pymakr 1.0.3 all worked fine. after last update I get: "Failed to load the Pymakr package" ... stacktrace.... then: The error was thrown from the Pymakr package. This issue has already been reported.
    View Issue ( https://github.com/pycom/pymakr-atom/issues/1 )

    is it possible to revert to 1.0.2?


  • Global Moderator

    This morning a patch has been released under v1.0.3.

    It fixes issues with serialport library on windows32 and problems in newer atom versions (1.17.2 and 1.18). If you had any installation issues before, this update should to resolve it.


  • Global Moderator

    A small patch has just been released under v1.0.2. It contains some fixes that will help pytrack/pysense users, for example when the board goes into sleep. The serial will now handle a loss and recovery of the serial port when the board goes to sleep.

    • Added timeout and reconnect logic on serial connection (useful for pysense/pytrack sleep)
    • Pysense/pytrack serialport detection
    • Bugfix related to project settings not refreshing (issue #23)
    • Ignoring hidden and empty subfolders during synchronize

  • Pybytes Beta

    I' m always having problems to sync with the boards, specially while connecting by WiFi it's almost impossible to sync or run a program.

    I have everything updated and using Windows10, am I the only one? Or is it "normal"? What do you recommend me to sync easier? Is it possible to connect with Putty by Wifi?



  • Clicking on that bug also gave me some hints: Some installed packages could not be loaded because they contain native modules that were compiled for an earlier version of Atom.Rebuild Packages and clicking rebuild: The system cannot find the path specified, it fails.

    edit: third time it worked!



  • @bucknall

    Thanks. I see what the issue is.... there is a small red bug in the bottom right corner of the screen. When clicking on it, it indicates that there is an issue with my serial library. It has a "rebuild" link. After clicking on it, and restarting Atom, it now works.

    Mike


Log in to reply
 

Pycom on Twitter