Wipy2 non responsive

  • I have two Wipy2's and both have the same problem. Worked ok for a while then no heartbeat led and no usb connection. They seem to be alive but the firmware is somehow corrupted. All the things I have read to try here have not worked. When trying to connect get "Failed to connect to ESP32: Timed out waiting for packet header, on line 75". Any way to fix this without recompiling and reloading the firmware?
    They were working, so the header pins and usb cable are ok.

  • OK so heres what I have found.

    On one board it works if connected directly to 3.3v, the onboard regulater seems to be not working.

    The other board has the ChipPU pin pretty much low all the time -- about 400mv, goes to 0v when the button is pressed.
    putting a pullup on that pin doesn't help, it seems to be shorted. So that board is in permanent reset.

  • Using expansion board with nothing else connected except the USB cable. Can not reload firmware because the loader doesn,t connect.
    Have ordered a Jtag adapter which will be here next week,
    On one of the boards if I put it update mode (G23 -> gnd) and look at the output with a serial terminal, I get a continuous bunch of mixed text and binary. The other board I get nothing.

    I have found post else where that seem to be the same problem, but never have a resolution.

    And I get the same usb connection if the wipy is in the socket or not, which tells me I am just seeing the ftdi connection.

    I think I'll try connecting directly to the board without the expansion board to eliminate that possibility. just have to try to find my 3.3v serial to USB adaptor.

  • @sgehrs
    The boot code - used in firmware upgrade mode - is held in ROM on the ESP32 so as far as I know it wouldn't get corrupted or erased.

    Do you have any other pins connected other than the UART? The ESP32 has some strapping pins which if set to the wrong value at boot will impair operation, namely make sure there is nothing on

    P9 • MTDI/GPIO12: internal pull-down
    P2 • GPIO0: internal pull-up
    P8 • GPIO2: internal pull-down
    P3 • GPIO4: internal pull-down
    P4 • MTDO/GPIO15: internal pull-up
    P5 • GPIO5: internal pull-up


    P3 in particular seems to trigger a chip test mode

  • @sgehrs Are you using an expansion board to connect to your WiPy or a serial usb cable/connection?

  • Yup, tried pretty much everything, it's like the boot code is corrupted or erased. I'm on Linux and get a /dev/ttyUSB* connection but nothing happens. Tried the ESP tools also, but no usb activity. Like I said previously it was working, and I was going t modify the code and it just would not connect. I am looking at my JTAG adaptors to see if one them will work on the ESP32. Also going to dig out my 'scope and see if the clocks are there.

  • @sgehrs
    Have you tried updating the firmware using the Firmware update tool?

Log in to reply

Pycom on Twitter