Firmware upgrade



  • We've just published a new firmware update. Version 0.9.2.b1 release includes:

    • Fix issues with some devices that were unable to take previous updates.
    • Add the I2C class to the machine module (with support for 1 bus at the moment).
    • Increase the FreeRTOS timer task priority in order to guarantee that the LoRa task will always run.

    It is now available at: https://www.pycom.io/support/supportdownloads/

    Notes:

    1. This upgrader tool requires a serial connection. WiFi connection is not possible for this special upgrade.
    2. You can find the documentation for the new I2C class at: https://docs.pycom.io/lopy/library/machine.I2C.html


  • sorry this is not on this page i have two pages open in browser
    this was for https://forum.pycom.io/topic/88/how-to-solve-the-firmware-update-failures/54

    i do not see possibility to edit post or delete it on this forum :(



  • @LarryTru
    you are the best :)

    This work for me - but Pymark still can not connect to WiPy2.0 :(
    Before upgrade it work ok.
    I can only conect by: wifi, ftp, telnet
    boot.py looks ok
    I also can see data sended by UART programmatically on com port monitor but Pymark can not :(



  • Clarification for anyone who may get tripped up by this minor detail (as I did)...

    The firmware updater has several steps and one of them describes adding the jumper and connecting the LoPy to your PCs serial port.

    I tried to follow the guidence in the firmware updater strictly and therefore I connected LoPy to my laptop's USB port at the point in the process where that is described.

    However, (at least on my mac) you actually have to do that before starting the firmware updated or you will not be offered the correct port to choose.

    So, add the jumper and connect the serial port first; then run the firmware updater.

    Both my boards updated without incident using this process.

    Larry


  • Global Moderator

    said in Firmware upgrade:

    Add the I2C class to the machine module (with support for 1 bus at the moment).

    On the LoPy which ones are the I2C pins SDA/SCL?



  • @abilio
    Tried upgrading with latest using the Pycom Firmware Update tool for WIndows.

    1. turned off device
    2. connected P2-GND
    3. connected USB (i'm on Win7)
    4. turned on device
    5. Selected proper Com port (which has working REPL)
    6. The upgrade failed

    At one point the led got solid green.
    When i start putty and reset the board (P2-GND still there) the terminal shows:
    rst:0x1 (POWERON_RESET),boot:0x3 (DOWNLOAD_BOOT(UART0/UART1/SDIO_REI_REO_V2))
    waiting for download

    i'm unsure when to remove the P2-GND and/or reset the board in this whole procedure...


Log in to reply
 

Looks like your connection to Pycom Forum was lost, please wait while we try to reconnect.