Cannot connect to WiPy 2.0 via USB



  • Hello!

    I just received my WiPy 2.0 and expansion board. It seems to work, in the sense that the blue led flashes every 4s and I was able to connect to it via the PyMate application for iOS.

    However, I am not able to connect to it via USB on my MacBook running macOS Sierra.

    I know there are other threads about this problem, but none of the proposed solutions worked,so here I am :)

    Here's what I verified/tried:

    • I connected G23 to GND in order to be able to flash the board (I'd like to install espruino on it) and the blue led stops flashing correctly.
    • the board powers up when connected.
    • the board is connected properly with the expansion board
    • the RX and TX jumpers are in place... two jumper cables are missing btw, is that a problem? Are all jumper cables supposed to come with the expansion board?
    • I tried unloading the Apple FTDI drivers --- they weren't installed.
    • I installed the CP210x USB to UART Bridge VCP Drivers
    • I installed the FTDI VCP drivers
    • I used different cable, including the one I used to flash my Feather Huzzah.

    ...still, nothing shows up under /dev/when I connect the board with my Mac. And yes, I also tried the pycom updater and it only detects a Bluetooth incoming port on my mac when the board is plugged in.

    Any ideas? :(

    Thanks in advance...



  • Solved! These are the right drivers to install!

    http://www.ftdichip.com/Drivers/D2XX.htm



  • @robert-hh Thanks. I went through it and the only positive thing is that I can see a "FT230X Basic UART" listed under "USB" in OSX System Report, which is then removed when I disconnect the board... however I still don't have any suitable device listed under /dev -- so close! Why is this happening, if it's recognised by the driver?



  • @h3rald Did you look at all the discussion in this post:
    https://forum.pycom.io/topic/919/firmware-update-not-possible-on-either-windows-or-mac-osx/21
    It's lengthy but covers various aspects and attempts.
    Also the proper driver should be here: http://www.silabs.com/products/development-tools/software/usb-to-uart-bridge-vcp-drivers
    But I guess you tried that already.



  • @robert-hh thanks for your reply... I don't see the correct cu* or tty* device in /dev, that's the problem :( I think it's a driver problem, but I am not sure on what drivers I need -- I think I installed everything that was mentioned in other threads... any other idea?

    Also:

    • I am using a USB2 port, it's a 2011 MacBook Air
    • I only got 4 out of 7 jumper cables :( but I am not that bothered


  • @h3rald Do you see the proper device in /dev when the expansion board is connected. It's name is like /dev/cu.usbserial-Dxxxxx
    If you do not see such a device, then either the cable or the driver are not appropriate.
    P.S.: All jumpers are supposed to be delivered with the expansion board. If not, it's a shipping fault.
    P.S.2: Someeone mentioned that using an USB2 port instead an USB3 made the difference, but that was with Windows, and the actual reason could be different. Windows reinstalls/remaps the driver if the device is used on a different port.


Log in to reply
 

Looks like your connection to Pycom Forum was lost, please wait while we try to reconnect.