Can't edit/change files



  • I just got my WiPy 2.0 yesterday. It first seemed to work fine and I started trying to connect to my home wifi. I couldn't get it to work though, and when I tried again today I noticed that whatever I do I can no longer change the files on the board. The REPL via telnet works fine.

    If I delete a file it first appears to be gone, but if I restart the board, or even if I just try uploading a new file, it all gets reset back to the same state.
    The files it keeps restoring is a modified boot.py, an unmodified main.py and a log.txt with one line of text created from my boot.py as debug to see what was going on.

    I've tried deleting both from REPL with the os module and from FileZilla, and the behaviour is the same, the file first seem to be gone but as soon as I try uploading anything it gets restored.

    I've tried this both in normal boot mode and in safe boot, no difference.
    Same thing when booting to the factory firmware, but since I haven't done any firmware update, I'm guessing all options should run the same version.

    I also tried to reset the filesystem with os.mkfs('/flash'), but nothing changed.

    I haven't got an expansion board so wifi is currently my only option. According to the docs I should be able to update the firmware over wifi, but there's no info on where I get the appimg.bin file, and I found this post claiming it's no longer possible.

    Also, although not really relevant to the problem, I tried downloading the firmware update tool. On my mac it simply won't open, nothing happens when I run the app. On windows the program works, but it just tells me to connect with usb so I can't really use it.

    Any ideas on what's wrong and how to fix it?



  • I managed to find a USB-to-serial adapter and tried some things with that. My Windows machine won't recognize it, and on my mac I can't figure out what tty port it's on. I did however dig out a Raspberry Pi where it seem to work.
    Unfortunately it didn't help, because the linux-version of the pycom updater just keeps saying "Something failed trying to connect to the device." and then gives no further info.
    I also tried modifying the baud rate in the updater.py script as some thread suggested, but no luck.



  • @SesamProductions
    With this very old firmware version there is not possibility to update by Wifi


    In current version of firmware also is not possible
    https://github.com/pycom/pycom-micropython-sigfox/issues/5


    To update to current firmware you must have
    expansion board
    or UART/USB converter e.g. https://forum.pycom.io/post/7176



  • Just thought of checking os.uname().release, and it returns '0.9.0b'.
    Does that mean I still can update firmware over wifi?


Log in to reply
 

Looks like your connection to Pycom Forum was lost, please wait while we try to reconnect.