Pymakr does not show lopy files in File-Browser



  • Sorry if this is a noob question, but I can't see files (boot.py, main.py) in pymakr. From the announcement it seems like it should: "It’s a fully featured IDE that connects automatically to your Pycom devices via Telnet Server or serial port, runs your code on the fly, manages the internal file system,"

    I upgraded my lopy's successfully using the stand-alone updater, I can connect to get a REPL prompt over wifi or USB/UART.

    When I click on the File-browser tab in pymakr, a window pops up titled "pythonw" and containing the warning: "Warning:
    QFileSystemWatcher: failed to add paths: D:"

    If I use Filezilla I can see all the files in /flash, and I can download them. Boot.py just ahs the code to duplicate the REPL on the uart, as expected.

    I am using Windows 10, 64 bit and pymakr 1.0.0.b5. I disabled all antivirus software just in case.

    I guess I can download using filezilla, edit the files in notepad++ and upload them again using Filezilla. And I can watch what is going on using USB, using RealTerm or pymakr. But then I wonder what the use of pymakr is?



  • This post is deleted!


  • Hi @Shaun,

    Thanks for the suggestions. The '2 way sync' is something we are discussing to implement. Upload of config or resource files is also not fully supported at the moment, so for now you'll need an FTP app to do this. I'll put this on our list to research. For all development of your python code, pymakr will do the trick.



  • @Ralph
    I too expected to be able to access the file and folder structure of the Lo/WiPy using Pymaker, as I understood I would no longer need any other application to develop with Pycom products.

    I would like to be able to retrieve files that have been created by a python script (Eg log files) running on a Pycom product and I would also like to be able upload resource or config files that are separate from a python project.

    Thank you.



  • @digsatman thanks it worked for me as well! I just had to do the actions in reverse order (disconnects from server then process queue)



  • I have only uploaded once using Filezilla, and it worked okay for me.



  • @aureleq I too have had very little success with filezilla - a trick I did discover was to establish a connection and then put the file(s) I wish to transfer in the "Queued Window" of fiezilla and then click on the "process queue" in the transfer window. When nothing seems to happen, click on the icon that "disconnects from the currently active server" whereupon the files will transfer and the connection then dropped. I've only tried this with small files but it seems to work reliably.

    I'm using Filezilla 3.22.1 under WIndows 7 (64 bit). When I was trying to upload new firmware into the flash/sys directory (before the stand-alone updaters were fixed) - I had to resort to using my Android phone and using FTP in an app called "ES File Explorer" - This worked better with large files but was still unreliable but better than filezilla using the same "passive" and single connection you mention.



  • Thanks for the info!
    Is there an alternative way while waiting for a fix? With FileZilla I can download files but upload always times out. Maybe I missed some config though I am in passive mode and 1 simultaneous connection only.

    Aurelien



  • @aureleq There is a problem with sync at the moment - it is due to be sorted soon as per the thread at https://forum.pycom.io/topic/153/pymark-sync-project-failed



  • @w0run have you managed to make it work?
    I am trying to upload a source file and I followed the project creation process. When I try to synchronize I have the same sync failed problem...
    I tried with both USB and WiFi setup in PyMakr but no success so far



  • After the sync failure reported previously, I discovered that boot.py was empty (0 bytes). So REPL was not being duplicated on the uart. I restored it with Filezilla and all is well again. So the Pymakr sync function has some problems, at least in Windows 10.
    I have tried this a couple of times now, with the same results.



  • Sadly that did not work either. I created a new project and added boot.py and main.py that I had downloaded using Filezilla. All seemed fine. I modified main.py a little bit and then tried to sync the project. this is what I got:

    Connecting to a LoPy...
    MicroPython a78d0fa on 2016-10-21; LoPy with ESP32
    Type "help()" for more information.

    Syncing the project with the LoPy. Please wait...
    Syncing failed!

    Reattempting in a few seconds...
    Connecting to a LoPy...
    Error while communicating with the LoPy! (click to attempt to reconnect)

    At this point I had to power cycle the LoPy to get it to connect again.



  • Thanks, I will try the project approach and see.

    To answer the question: Yes, I can see all my files on my PC using the File-Browser. I see a folder for D:, which is the lopy, but it is empty. It seems that if I click on it a few times, I eventually get a more serious warning:

    "Warning:
    An unhandled exception occurred. Please report the problem
    using the error reporting dialog or via email to support@pycom.io.
    A log has been written to "C:\Users\Gordon_pymakr\pymakr_error.log".

    Error information:

    2016-10-28, 09:23:34

    <type 'exceptions.TypeError'>:
    'NoneType' object has no attribute 'getitem'

    File "C:\Program Files (x86)\Pycom\Pymakr\Pymakr\Plugins\PluginPycomDevice.py", line 90, in __onWindowLoad

    Actually I don't know whether it is clicking in the File-Browser or some other action.
    Woould you like me to send the error log?



  • @LarryTru thanks for that suggestion, we'll take it it into consideration. For now, if your implementation requires you to write files to the flash and then download them, you'll have to manually retrieve them.



  • @Ralph If I understand correctly, the gist of what you are saying is that it is only able to synchronize in one direction; Pymakr to LoPy. Hopefully it will be bidirectional in the future, because this means that any files your code writes have to be manually retrieved via ftp.



  • Hi @w0run ,

    Sorry for this announcement being a bit confusing. The easiest way is to use project-viewer instead of the file browser. There are two ways to start out. You can create a project, then create the boot and main files manually. Or you can use this method:

    • Download the boot and main file to a folder on your pc using filezilla or other FTP program
    • In Pymakr, create a new project, select the folder where you put the files
    • When asked if you want to add existing files, choose yes

    If you manage to do that, the only thing left is configuring your device in the preferences and start using the synchronize and run buttons to put the code you write on the device.

    The "pythonw" popup error is something we will look in to. It seems to be an issue only with the windows version. Are you still able to see the files on your filesystem in the FIle-browser tab after getting this error?


Log in to reply
 

Looks like your connection to Pycom Forum was lost, please wait while we try to reconnect.