Updater Fails on all platforms



  • Hi, When i run the updater i get the error "Something failed trying to contact the server.". I have tried on linux, windows and OSX.



  • Thanks for the super fast reply @robert-hh

    • I am using bare board
    • yes i can successfully connect to the device- in normal boot i get the python prompt, and with the jumper on GP23 i get "waiting for download"
    • Pc is connected to the internet
    • As above GPIO0 is tied to ground

    I have just solved the issue- i had selected the south african server in the menu, which failed.
    I now selected Europe (because it's also RCZ1) and this worked perfectly.

    Thanks again for the help!



  • @shaulf Some questions:

    • Which set-up are you using? Bare board or board with expansion board.
    • Can you connect via USB to the device (using e.g. Linux picocom, Windows Putty or OS X Screen) and get a Python prompt? The devices are semnt with a firmware loaded.
    • Does PC you are using have a connection to the internet.
    • Did you connect GPIO0 (= GP23 or P2) to GND and reset the device, before you started loading?

Log in to reply
 

Looks like your connection to Pycom Forum was lost, please wait while we try to reconnect.