Windows Users - Firmware upgrade



  • After receiving reports from Windows users on an issue with the firmware upgrade tool, we suspect it could be related to the way we've been running the program, using pythonw.exe.

    There is out a new version of the file, v.0.9.2.b2b (download from here), that uses python.exe by default. Running the wizard, a new command dialog will now appear in the back.

    For those users willing to give new feedback, a copy of the text in that dialog will be highly regarded.

    The firmware itself continues to be the same: v.0.9.2.b2. The features were reported earlier in this other thread.

    Note: MacOS and Linux installers remain the same for this time. Only Windows users seem to be affected.



  • @abilio

    When I was using Pythonw,.exe, if I want to get the scripts to execute with pythonw instead of python, I had to rename the extension of the .py files to .pyw.

    I also needed to register pythonw.exe as the application to execute the .pyw files. This was slightly different in Windows 7 than Windows XP. The installer for the FW updater should be able to register pythonw as the application to run the .pyw files.

    Good luck



  • Yeah @n0ahg, that could be the reason. Thanks a lot for the suggestion :)



  • Could this be to do with stdout,stdin,stderr being invalid file descriptors when your script is running under pythonw.exe?

    See http://bugs.python.org/issue706263



  • Yes @cappy2112, that's why we were initially using pythonw, as we also do on Pymakr, to make it look like a clean Windows app. But the upgrade process failed. With no changes to the code, running the thing on python.exe made the trick. I'll still have to figure out why.



  • @abilio

    "it could be related to the way we've been running the program, using pythonw.exe"

    If you use pythonw.exe, you won't see a console window. This is the intended purpose of pythonw.exe, as opposed to python.exe



  • @abilio Yes!!! This one does the upgrade well! Appreciate the status window in this version. Nice job,.



  • Worked perfectly first time on both of my LoPy


  • Global Moderator

    This one worked for me at the first attempt :)

    Guess I won't be needed any more ;)


Log in to reply
 

Looks like your connection to Pycom Forum was lost, please wait while we try to reconnect.