Compile firmware for wipy2.0 success, but after reboot is red light



  • Hi, ive tried to compile the firmware from scratch and to flash my wipy2.0. Ive followed the instruction from the github https://github.com/pycom/pycom-micropython-sigfox and all went fine.
    I`ve successfully flashed the firmware, to the point when the board reboots. Then i unplug the wire between gnd and g23, and reboot the board, but instead of the blue blinking led now there is a full red. Only way is to reflash with the flasher tool.
    any help is appreciated, thanks



  • @robert-Thank you, worked perfectly



  • @pedro You have to erase the flash before and then reload. There is an inconsistency between the pre-built images and the self-built ones. Erase the flash with:
    make erase
    and the reload with
    make flash
    You have to push reset before each make command, and the gnd/g23 wire has to be in place. Unfortuantely, the content of the local file system will be wiped out too.



Looks like your connection to Pycom Forum was lost, please wait while we try to reconnect.