How to check FW version.



  • What is the canonical FW version for the LoPy?

    Sorry if I missed something in the docs. But I'm having trouble getting the version of software in a script readable fashion.

    The sys module seems to not have the FW version in it.

    >>> __version__
    Traceback (most recent call last):
      File "<stdin>", line 1, in <module>
    NameError: name '__version__' is not defined
    >>> import sys
    >>> sys.version
    '3.4.0'
    >>> sys.platform
    'LoPy'
    >>> sys.implementation
    (name='micropython', version=(0, 0, 1))
    >>> 
    


  • Thanks! This works.



  • @hardkrash
    I think you search for

    import os
    os.uname()

Log in to reply
 

Looks like your connection to Pycom Forum was lost, please wait while we try to reconnect.