A million issues getting started



  • https://docs.pycom.io/pycom_esp32/pycom_esp32/getstarted.html Have been following this guide.

    I have a WiPy 2.0 and the expansion board.

    Starting out: I had pymate on my phone, connected to the device and uploaded firmware. This seems to break the wipy... I was no longer able to connect to it over pymate... fine... so I bought the expansion board.

    Following the guide, I get the firmware upgrader tool, follow the steps including setting 23 to ground. Says firmware upload is complete and to remove the cable and power off. I do this and power up again, still not showing up on WiFi for the pymate app on android.

    I tried installing Pymakr for atom, but that wont work as it gives an error saying Pymakr is broken as it was built for another version of atom.

    I'm starting to pull out hair and I don't know where to turn.



  • @AustinBeau
    yes i wrote this line from memory - fixed in post, thanks :)
    IP is 192.168.4.1 and rest default www.pycom.io
    and then micro python
    like here
    https://docs.pycom.io/pycom_esp32/pycom_esp32/getstarted.html#initial-configuration-atom



  • @livius I got WiFi to work again! But just to correct for anyone else reading, it's from network import WLAN not machine

    And to ftp to it, I set my machines WiFi network to the ssid I set, and ftp at 192.168.1.1 with user micro and password python?


  • administrators

    Hi @AustinBeau,

    To fix your Atom issue, you'll see a little red bug at the bottom of your Atom window. Click this and it will give you an option to rebuild the Pymakr Plugin. This should hopefully fix it for you!

    I will investigate the Pymate issues you're having but for the time being, I suggest that you put your device into 'safe boot mode' (https://docs.pycom.io/pycom_esp32/pycom_esp32/toolsandfeatures.html#safeboot) and then when the REPL is available, running the following commands:

    import os
    os.mkfs('flash')
    

    This will clear any of the files that were previously written to the device by the Pymate app.

    Thanks!

    Alex



  • @AustinBeau
    You probably are affected bu current "issue" with wifi where you must set ssid in AP init
    look here for details:
    https://forum.pycom.io/post/8950

    connect to your board by UART
    use e.g.
    putty or
    Arduino IDE and there is com port monitor - set baud rate to 115200 and change linebreak
    try simple command like os.uname()
    if this worked try this lines:

    from network import WLAN
    wlan = WLAN(mode=WLAN.AP, ssid='wipy-test')
    

    after this you can connect to it by ftp e.g. filezilla
    and put above lines in your boot.py
    after reset your wipy will be avaiable as wipy-test
    and you can simply connect to it

    about other issues you have i can not help, i do not use atom plugin


Log in to reply
 

Looks like your connection to Pycom Forum was lost, please wait while we try to reconnect.