New Pytrack and Pysense firmware release (0.0.4)


  • administrators

    Hello,

    Firmware release 0.0.4 for Pytrack and Pysense is now available. Here's the change log:

    • Recover gracefully from I2C bus errors.
    • Implement I2C slave clock stretching in order to avoid Rx buffer overflows.

    Basically this new firmware solves a bug that would cause the Pytrack or Pysense to become unresponsive on the I2C bus until a power cycle was performed.

    Please follow this instructions in order to install the new firmware: https://docs.pycom.io/chapter/pytrackpysense/installation/firmware.html

    Important: When applying this release to a Pytrack or Pysense board, make sure to be running the latest firmware on the Pycom module as well, since clock stretching support was only added 2 releases ago (on 1.7.5.b1).

    Cheers,
    Daniel



  • @jmarcelino It turned out when I used a different computer it worked first time. Thanks for the help anyway I think it may have been a motherboard issue.

    thanks,

    Chris



  • Is it now possible to wake up from deep Sleep (py.setup_sleep(SLEEP_TIME) & py.go_to_sleep()) from one of the EXT_IO header ?



  • @chrisi
    Did you connect the USB while pressing the button on the Pytrack/Pysense? Also remember you only get about 6 seconds to run the dfu-util command after that, goes quite quickly.

    You might also need to run it with sudo.



  • I have tried updating both the Pytrack and Pysense but keep on getting the error "No DFU capable USB device available". I have tried both Debian on a raspbian and Fedora on a computer. Have tried all com ports on devices and different cables. Any Ideas?

    Thanks,

    Chris


Log in to reply
 

Looks like your connection to Pycom Forum was lost, please wait while we try to reconnect.