IMPORTANT: New Firmware Update Tool Released (version 1.1.2.b1)


  • administrators

    Hello,

    We have released a new updater tool for all 3 Operating Systems (Windows, Linux and Mac OS) v1.1.2.b1. This new tool is required to flash firmware versions 1.7.7.b1 (to be released later today) onwards. Using the previous tool to flash firmware will result in the module being temporally bricked (flashing them again the proper way will solve it).

    From now on, the old tool won't work anymore as our software server only replies to request of the new tool.

    Please make sure to get the new version before upgrading your boards again. Thanks!

    The firmware update tool is available here: https://www.pycom.io/downloads/

    Cheers,
    Daniel



  • Update was succesful on another WIN10 machine.



  • LoPy update fails on WIN10 (64-bit). Connecting to the device with a serial terminal using 115200 bit/s I see

    rst:0x1 (POWERON_RESET),boot:0x3 (DOWNLOAD_BOOT(UART0/UART1/SDIO_REI_REO_V2))
    waiting for download

    but the PyCom updater fails to connect.

    Updater is just downloaded as 1.1.2.b1

    Version number is not displayed in the updater and clicking on '?' in the upper right corner nothing happens. It looks like there is no way to get installer version.



  • @daniel It works, report 1.7.7.b1

    os.uname()
    (sysname='LoPy', nodename='LoPy', release='1.7.7.b1', version='v1.8.6-715-g5fa16c2c on 2017-07-20', machine='LoPy with ESP32', lorawan='1.0.0')



  • @daniel Now it works.



  • @daniel 1.1.2.b2 worked on my Ubuntu 16.04 Thanks....


  • administrators

    @robert-hh can you please try again? The issue reported before was caused because of the slow baudrate (38400) used before for the initial connection with the board. Increasing it to 57600 fixed it. We just trying again on our Ubuntu machines where it was failing before and now it's all fine.

    @Emmanuel-Goudot @b3da @rdixey could you please try and let me know? Thanks!



  • @daniel tried it, got a little bit further, up to the message:
    " Something failed trying to contact the server."


  • administrators

    Hello everyone,

    Thanks for reporting this issue with the linux updater. We haves just fixed it and released version 1.1.2.b2 for unix. It's available here:

    https://software.pycom.io/findupgrade?product=pycom-firmware-updater&type=all&platform=unix&redirect=true

    Apologies for the inconveniences...

    Cheers,
    Daniel



  • Same issue on ubuntu: cannot update LoPy/SiPy anymore...



  • @robert-hh exactly the same for me on Ubuntu: Changing baud rate to 921600 - Failure!



  • @daniel Did you find any specific issue with Update Tool 1.1.2.b1 on Ubuntu?



  • Works ok here on Linux Mint 18.1 64 bit

    ´´´

    os.uname()
    (sysname='WiPy', nodename='WiPy', release='1.7.7.b1', version='v1.8.6-715-g5fa16c2c on 2017-07-20', machine='WiPy with ESP32')

    ´´´


  • administrators

    @rdixey I just tried the Unix it on Mac OS. Works as normal. I'll try this on Ubuntu tomorrow, and see if there's an specific issue there.



  • @rdixey Same here. It stops after changing the baud rate to 921600. Updating a self-built firmware with esptool.py initiated with "make flash" works.
    OS Debian 8



  • I deleted all previous versions of the Update Tool from my Ubuntu system. Then downloaded the New Firmware Update tool v1.1.2.b1 from pycom.io Pycom upgrader Linux link.
    When I run it as I have dozens of times in the past I get the messages:

    • Connecting to the device to get it's information, please wait.
    • Something failed trying to connect to the device.

    Looks like the .update bash script throws this message when updater.py can't establish the serial connection

    I'm using /dev/ttyUSB0 through which I routinely connect to the Lopy with Screen at 115200 baud.

    I don't understand why the new update tool can't establish the connection as it had so easily with the prior update tool?


  • administrators

    @jcaron good point about the version numbering for Mac OS. We'll get this fixed next week, but it's just that the version number was not increased, the updater is the correct one.

    are there any changes required if using updater.py on the command line (which allows changing the bps) as opposed to the GUI?

    No, all the scripts have been properly changed, so using them on the command line is also fine.

    Cheers,
    Daniel



  • When downloading the macOS version, the .dmg is indeed numbered 1.1.2.b1, but the "Pycom Firmware Update" it contains is still numbered 1.1.1.b1.

    Is the version number incorrect, or the updater?

    Also:

    • in some situations, upgrading at 115200 bps just doesn't work. An option to select 57600 would be great.
    • are there any changes required if using updater.py on the command line (which allows changing the bps) as opposed to the GUI?

    Thanks!



  • @daniel
    Wow some pretty good changes there!

    I love Fridays ;-) Thanks



  • @daniel Thank you.


Log in to reply
 

Looks like your connection to Pycom Forum was lost, please wait while we try to reconnect.