W01 Information / version / got one going



  • Hi. I got some W01 modules then promptly wired one onto some board - and it works fine. Sure, the soldering is difficult - but doable. Check closely the next day is best.
    The PSU I used is a polulu S7V8F3. I put 4 off 100nF caps on the W01 Vcc pin as well as 3 off 100uF caps in parallel and kept all leads short and fat as I could.
    For an antenna I made a dipole from FR4 single sided pcb - each arm 30.5mm and gap between the arms of 6mm - width of arms 5mm (ie quite fat - for bandwitch I guess) - wisdom of the internet design. Not used the radios yet.
    I'm feeding Vin to the regulator with a new 4 off AA cell pack of NiMh batteries - approx 5V. I see approx 95mA currrent into the switching reg (seems high) - need a little more testing on that - maybe droop on the NiMh cells. I'm using a USB-Serial 3V3 adaptor - seems ok - I fitted 270R resistors in the RxD and TxD lines for voltage differentials etc.

    I get an REPL on Serial port 0 - at 115,200 baud N81
    I get version information of 3.4.0
    I get Mem_free of 2040688
    I get this in the startup messages..
    "MicroPython v1.8.6-621-g17ee404e on 2017-05-25; WiPy with ESP32"

    Haven't tried WiFi connecting yet - very soon. That will test the PSU and caps and antenna I guess.

    I'm not seeing much information on the W01 modules - etc. I looked - any links/hints appreciated.

    My real questions - what is the latest firmware that can be upoloaded? I'm hesitant to use the "new updater" without some information saying it is fine. I'm wanting to use the serial port for now.

    Rather pleased it worked 1st time.
    Cheers - Richard


Log in to reply
 

Looks like your connection to Pycom Forum was lost, please wait while we try to reconnect.