[SOLVED] Can't flash firmware



  • My first WiPi. My first attempt to flash the firmware. I am using the app on MacOS. The result is "Connecting............... Failure" every time. The proper device shows up in the port dropdown. I have tried hitting the reset button just before attempting as well as have unchecked High speed transfer.

    I might be able to try on a second Mac to see if it is any different, but I want this MacBook to work.



  • @tinjaw
    Thank you. The original WiPy (version 1) is not supported by the Pycom updater, the updater is only for the newer ESP32 based board (WiPy 2, LoPy, SiPy..)

    For the original WiPy you can download updates from the MicroPython site: http://micropython.org/download#wipy and install via FTP as described.



  • @jmarcelino I am using the expansion board. I have a jumper from GND to G23.

    alt text



  • @tinjaw
    Can you describe your setup? How are you flashing the WiPy, are you using the Pycom expansion board? Did you connect the GND pin to G23?


Log in to reply
 

Looks like your connection to Pycom Forum was lost, please wait while we try to reconnect.