Unable to upgrade (Mac OSX)



  • I've been trying the new app to upgrade my LoPys but failed. The app reports that it couldn't connect to the device.
    The version I've tried is v.9.2.b2a
    Both chips are fine as I'm able to connect through WiFi. My Mac (OSX El Capitan) reports the serial devise as /dev/cu.usbserial-DQ008RYY and it shows up in the dev directory as soon as I connect the USB cable to the expansion board. I have tested the jumper and it has continuity.
    What else I could try?
    Thanks in advance.

    Here's my LoPy. :-)

    0_1478179141675_IMG_2188-s.jpg



  • Yes!!! This solved my problem as well. This note should be added to the official quick start documentation!

    Cheers,
    Phil



  • @fcabrera The one that is marked in this photo.

    According to @Ralph if you don't have the extra jumper (a little black connector) to short the TX take off the one at BAT and use it in TX instead.

    0_1478201007503_jumper-tx.jpeg



  • Im having the same problem, what is that jumper? Connections? Thanks



  • @Ralph said in Unable to upgrade (Mac OSX):

    tx jumper

    Yes!!! That was it! It had probably fallen when I unpackaged it.

    Thanks a lot.


  • Pybytes Beta

    @Xykon Oh I see... thanks for the head ups.


  • Global Moderator

    @jomifo said in Unable to upgrade (Mac OSX):

    I've been able to successfully upgrade the firmware on OSX using the ftp method.

    That won't fix the issue with the bootloader setting the flash memory read-only by error. You should really upgrade via the serial port method.


  • Pybytes Beta

    I've been able to successfully upgrade the firmware on OSX using the ftp method.



  • Hi @herchu,

    Thanks for the information and especially taking the effort to upload the picture. It looks like your tx jumper is missing on the richt bottom of the board in this picture. I'm quite confident that re-enabling this jumper will solve your problem :) Possibly it's still in the box it came in, but otherwise you could take the 'Bat' jumper and place it on the Tx pins.


Log in to reply
 

Looks like your connection to Pycom Forum was lost, please wait while we try to reconnect.