PyMate (iOS) does not connect to WiPy 2.0



  • Hi my fellow PyMates!

    I cannot get my iPhone 7 to connect with a WiPy 2.0
    Steps followed:

    1. Download iOS App
    2. Register new account
    3. Followed process as outlined also in the youtube video

    The device remains red. After that, I updated to the latest firmware and using the Atom with the Pymkr plugin used the following command:

    import os
    os.mkfs ('/flash')

    After I pressed the reset button, the WiPy was back in factory settings.

    I repeat the process but again failed.

    I then reset again, and manually entered the wifi settings but again cannot connect.

    The error I get at the traceback is the following:

    File "boot.py", line 39, in <module>
    File "/flash/lib/pymate_basic.py", line 13, in <module>
    File "/flash/lib/pymate_library.py", line 402, in run
    File "/flash/lib/pymate_library.py", line 377, in _close
    File "/flash/lib/simple.py", line 109, in disconnect

    OSError: [Errno 113] EHOSTUNREACH

    In the meanwhile, the WiPy is connected to my network and it has a DHCP issued IP address.

    Can you help please?


  • administrators

    Hello everyone,

    I was able to rebuild the iOS Pymate app for iOS 11.0.2 and I'm getting some very basic functionality out of it.

    There are still some bugs that I need to fix before I can try to submit this new version to the Apple App Store. There are also some aesthetic issues but I'm ignoring them for now.

    I'm hoping to have some more news in the next few days.



  • Hi my fellow pymates,

    The forum died, the Pymate Server is still dead and even though the forum was restored (loosing this thread...) the problem still persists.

    I tried to overcome Pymate with Blynk but it seems that WiPy 2.0 is not supported.

    I am very disappointed... The overall behavior of the devices is much lower than expected and we are stuck with hundreds of Pycom products.

    We need to make the hardware work as it is marketed on the website. It's supposed to be an easy IoT Platform for everybody.

    Can anybody help?



  • @xykon Thanks! Let's fix this issue because it will be very nice for people new to the Pycom products experience IoT!


  • administrators

    @hellasdigital We've had some issues with the forum and unfortunately our discussion didn't survive the rollback.

    I had a chat with @ficofer earlier and we'll continue troubleshooting this issue tomorrow. We'll keep you updated on our progress.


  • administrators

    I haven't used the PyMate app for a while so I thought I'd give it a try.

    From what I can gather via tcpdump on my router, the server running the PyMate service isn't responding.

    I'll try to reach out to the Pycom team to take a look at this.



  • Anyone?

    Either everybody has the same problem or only me!
    I have also sent e-mail to support but no response...

    Any help would be appreciated!


 

Hello World?

Pylife on Kickstarter - November 2018








Back Us On Kickstarter >

Pycom on Twitter