Font bug/resize bug/REPL bug/Plugin bug still present in 1.0.0.b6-1



  • I am sad to report that at least three reported bugs are still present in the latest PyMkr release:

    1. The font bug:
      Using Kubuntu 16.04 it is still impossible to change the font for the editor or the REPL.

    2. The resize bug:
      The bottom pane can not be resized once any process wrote output into it.

    3. The backspace bug:
      Most importantly the REPL backspace bug that has been announced as resolved is still there. To replicate type
      print("Hello World!
      into the REPL (note the missing closing bracket!). Then press backspace.
      This is the Error it throws:

    --------------------------------------------------------------------------------
    2016-11-04, 20:48:14
    --------------------------------------------------------------------------------
    <type 'exceptions.IndexError'>: 
    string index out of range
    --------------------------------------------------------------------------------
    File "/usr/share/pymakr/modules/Plugins/REPL/Shell.py", line 565, in __write
    advance = self.__simulateVT100(s[i:])
    File "/usr/share/pymakr/modules/Plugins/REPL/Shell.py", line 535, in __simulateVT100
    if s[0] == 'K':
    
    --------------------------------------------------------------------------------
    Version Numbers:
    Python 2.7.12
    Qt 4.8.7
    PyQt 4.11.4
    sip 4.17
    QScintilla 2.9.1
    WebKit 537.21
    Pymakr 1.0.0.b6
    
    Platform: linux2
    2.7.12 (default, Jul 1 2016, 15:12:24) 
    [GCC 5.4.0 20160609]
    

    Furthermore the backspace sometimes does not delete the first character of a line.

    1. It still isn't possible to check or uncheck the chekboxes for activate and autoactivate in the Plugins Info window.

    Right now I am sorry to say that PyMakr isn't worth the hassle. After giving it a rest for a week or two I returned to the new version still constantly fighting it and its idiosyncrasies. Right now using the editor of my choice (Vim or Atom) with some commandline tools gives me a lot more control and configurable work environment than PyMakr. (Not that without any usefull information on the hardware or implementation of some of the advertised core functions it would be possible to do anything productive at all.) I understand that this is a new product and is far from complete but I do not have the time to beta test and fight with a product that does barely deliver what has been advertised. So far this has been a rather frustrating experience. And I am not listing any of the random errors it has thrown at me so far, as I wasn't even able to reliably replicate them. A dysfunctional IDE is a show stopper. Period.



  • @peter,

    Thanks for the detailed report. I'll try to work out why I can't manage to reproduce this and will try your steps on some other installations we have here.

    Sorry, I was unclear about the 'text entry' setting: I ment the system setting for ubuntu itself, not a Pymakr preference. I'm not convinced this will solve your problem but it's worth a try in the meantime.



  • I did not have much time today, but I tried to reliably reproduce the backspace bug:

    1. Start PyMakr with an attached LoPy.
    2. Goto REPL.
    3. Type print("Hello World!" (again note the missing closing bracket!)
    4. Type backspace.
    5. The error is thrown after one to four keystrokes. It worked every time I tried it. It also occurs with other lines but requires more backspaces to pop up.
    6. BTW it is the same with single quotes.

    I also tried to locate the "text entry" option in the settings but failed. It certainly is not in the Shell tab of the settings. I also tried the search function of the settings dialog, no luck. Where should it be?

    In the Settings/Preferences/Interface/Interface tab there is a language option which is set to "English (default)". I am not sure this is the one you mean.

    In reply to 4.: Maybe then checkboxes should not be used to provide read only status information. It creates false expectations.



  • Hi @peter,

    Thanks for the bugreport and I'm sorry that you had a bad experience with Pymakr. We'll do our best to solve all the issues as fast as possible, but it's a lot of work to do so on all platforms and possible configurations.

    1. Known issue, still on our list to change.

    2. Also a known issue and will be changed. It's hard to reproduce though. Can you tell me when exactly the pane can't be resized anymore? After any print() from the connected device?

    3. Also hard to reproduce for me (i'm using ubuntu 16.04 as well, don't have an IndexError). But, it might have to do with the fact that the US international text input, places the double quotes (") only after you press space. We'll figure out a way to fix this bug by properly handling this in the REPL screen, but until then you could solve it by disabling the "English (US, international)" text entry in the settings and just leave English (US), if that doesn't bother you otherwise. Let me know if this works for you as well.

    4. This is not supposed to be possible (it's how Eric works). The checkboxes are just to show the config, not to change it. Each plugin decides if it's autustarted and activated from inside it's code, and it can't be set from the user side.



  • I can confirm all findings... having WiPy 1 and LoPy but frustrated by the use of PyMakr... generally "the tools that reduce productivity are not the right tools"... back to my proven UltraEdit, FileZilla and Putty... and maybe later try PyMakr again... maybe...


Log in to reply
 

Looks like your connection to Pycom Forum was lost, please wait while we try to reconnect.