New firmware release version v1.9.2.b2

  • Hello everyone,

    This release contains the same changes as v1.9.1.b1 and fixes the issue with the safe boot introduced there.

    The full change log is:

    • esp32: Fix an SSL / TLS non-blocking socket problem. Thanks to @peterson79 for this contribution!
    • esp32: Remove all usages of unnamed unions.
    • esp32: Make sure that the LoRaWAN Tx done event is always triggered after the Rx complete event.
    • esp32: Add fileno method to the socket class.
    • esp32: Also store the channels, the channel mask and the ADR counters in the LoRa NVRAM.
    • esp32: Cast os.getfree() value to uint64_t to report correct sizes > 2GB. Thanks to @robert-hh for this!


  • @daniel
    I have upgraded device (WIPY2.0) from 1.7.2.b1 to 1.9.2.b2 and have problems:

    1. ntp_sync most of the time not wrok (hang and never ending)
      i use for it old method
    def getNTPTime(host = ""):
    	port = 123
    	buf = 1024
    	address = socket.getaddrinfo(host,  port)[0][-1]
    	msg = '\x1b' + 47 * '\0'
    	msg = msg.encode()
    	TIME1970 = 2208988800 # 1970-01-01 00:00:00
    	# connect to server
    	client = socket.socket(AF_INET, SOCK_DGRAM)
    	client.sendto(msg, address)
    	msg, address = client.recvfrom(buf)
    	t = struct.unpack("!12I", msg)[10]
    	t -= TIME1970
    	tuple_time = time.localtime(t)

    but also tested if rtc.ntp_sync could help but same result :(

    1. i2c not work - i2c buss error
      i init it with id=0 (i do not remember if in 1.7.2 it was hardware or software based)
    bus=I2C(0, I2C.MASTER, baudrate=100000, pins=("P19", "P20"))

    to test it what is going on i have updated board 3 times (all times sucessfully)
    but with the same result

    i have downgraded firmware back to 1.7.2.b1
    all work without any problems - any hint?

  • Hello
    I try this firmware and the exemple of nano Lora gateway and TTN

    It's OK for Uplink messages with ABP node.
    But with Downlink message (APB node) and join reponse (OTAA), I have this error for every incomming UDP message on the gateway from TTN.
    --> Downlink timestamp error!, t_us: 4294606989


  • Thanks for the quick fix!

Log in to reply

Pycom on Twitter