Sipy recognized as Lopy?



  • Hi guys, Some time ago I bought a new Sipy, flashed the current ( at the time) firmware, used for a couple of weeks only with wifi connection. today I was thinking to start using sigfox. When I tried to load the Sigfox library i got import error. then I tried:

    os.uname()
    (sysname='LoPy', nodename='LoPy', release='1.8.0.b1', version='v1.8.6-760-g90b72952 on 2017-09-01', machine='LoPy with ESP32', lorawan='1.0.0')

    what? my Sipy is recognized as Lopy?

    Then I updated the firmware:

    os.uname()
    (sysname='LoPy', nodename='LoPy', release='1.9.2.b2', version='v1.8.6-796-g489fafa0 on 2017-10-15', machine='LoPy with ESP32', lorawan='1.0.0')

    i can't understand..what's going on? Do I have a lopy with the sipy label on it?!

    how do I check/fix that?



  • hi Andrei, thanks for your reply!

    as the matter of facts, the version of the pycom upgrade I have installed didn't let me choose between the platforms, so i don't know how did I get the wrong firmware.

    anyway i'll follow the instruction in your thread. thanks again



  • @ozeta

    i did the same thing when flashing using the flashing tool

    https://forum.pycom.io/topic/2052/silly-firmware-mistak-sipy-thinks-it-s-a-lopy/2

    Andrei


Log in to reply
 

Pycom on Twitter

Looks like your connection to Pycom Forum was lost, please wait while we try to reconnect.